1050 String Subtraction (20分)——C/C++(字符串处理或Hash散列)

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

题目大意:

给定两个字符串s1与s2,输出s1中不包含s2的部分。

思路及分析:

两种方法,总有一种适合你,爆搜与Hash。
方法一:字符串长度不超过10^4,所以可以直接暴力搜索,双重循环找到不在s2中的字母,加入字符串s中;时间复杂度较高为n的平方。
方法二:Hash散列,使用map标记s2,然后遍历s1,把不属于s2中的字符存入s中;时间复杂度为n。

AC代码:

方法一:爆搜

#include<iostream>
#include<string>

using namespace std;

int main(){
	int t = 0;
	string s1, s2, s;
	getline(cin, s1);
	getline(cin, s2);
	for(int i = 0; i < s1.length(); i++){
		int flag = 0;
		for(int j = 0; j < s2.length(); j++){
			if(s1[i] == s2[j]){
				flag = 1;
				break;
			}
		}
		if(flag == 0) s = s + s1[i];
	}
	cout << s << endl;
	return 0;
}

方法二:Hash散列

#include<iostream>
#include<map>
#include<string>
using namespace std;

map<char, int> p;
int main(){
	int t = 0;
	string s1, s2, s;
	getline(cin, s1);
	getline(cin, s2);
	for(int i = 0; i < s2.length(); i++){
		p[s2[i]] = 1;
	}
	for(int i = 0; i < s1.length(); i++){
		if(p[s1[i]] == 0) s = s + s1[i];
	}
	cout << s;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值