VC Is All You Need

VC Is All You Need

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2033    Accepted Submission(s): 845


 

Problem Description

 

 



Three points example.
 



Four points example.

In this picture you can draw a line to seperate these 3 points in the two dimensional plane to keep points with the same color lie in the same side no matter how to color each point using either blue or red.

But in k dimensional real Euclidean space Rk, can you find n points satisfying that there always exsit a k−1 dimensional hyperplane to seperate them in any one of 2n coloring schemes?
 

Input
The first line contains only one integer T(1≤T≤105) denoting the number of test cases.

Each of next T lines contains two integers n,k∈[2,1018] seperated by a space.
 

Output
Print Yes if you can find one solution, or print No if you cannot.
 

Sample Input
3
2 2
3 2
4 2
 
Sample Output
Yes 
Yes 
No

#include<iostream>
using namespace std;
int main()
{
    long long k,n;
    int t;
    cin>>t;
    while(t--)
    {
        cin>>n>>k;
        if(n-k<=1)
        cout<<"Yes"<<endl;
        else 
        cout<<"No"<<endl;
    }
}

官方给的证明也看不懂啊。

不过也贴一下

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值