报错:bash: /usr/jdk1.8.0_202/bin/java: /lib/ld-liunx.so.2:bad ELF interpreter:没有那个文件或目录

在给服务器上的centos7安装jdk环境时遇到的这个问题。在这里插入图片描述

  1. 首先安装jdk时是参考的centos7下安装jdk1.8详细教程
  2. 跟着教程走了一遍,到最后java -version来确认是否安装成功时出现了这个错误。
  3. 根据错误原因找到了解决方法:yum命令下载glibc.i686
yum install glibc.i686

分析:

glibc是GNU发布的libc库,即c运行库。glibc是linux系统中最底层的api,几乎其它任何运行库都会依赖于glibc。glibc除了封装linux操作系统所提供的系统服务外,它本身也提供了许多其它一些必要功能服务的实现。由于 glibc 囊括了几乎所有的 UNIX通行的标准,可以想见其内容包罗万象。而就像其他的 UNIX 系统一样,其内含的档案群分散于系统的树状目录结构中,像一个支架一般撑起整个操作系统。在 GNU/Linux 系统中,其C函式库发展史点出了GNU/Linux 演进的几个重要里程碑,用 glibc 作为系统的C函式库,是GNU/Linux演进的一个重要里程碑。

安装过程中会询问是否安装等信息,直接输“y”即可。

  1. 安装好之后再输入“java -version”就会显示java的版本号及其他信息。这样就代表jdk安装成功了。
  2. 参考博客:CentOS7安装jdk后输入Java-version出现-bash: /usr/java/jdk1.8.0_271/bin/java: /lib/ld-linux.so.2: bad ELF in
  • 4
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值