分糖果
题目描述
某个幼儿园里,有 5 5 5 位小朋友编号依次为 1 , 2 , 3 , 4 , 5 1,2,3,4,5 1,2,3,4,5 他们按照自己的编号顺序围坐在一张圆桌旁。他们身上有若干糖果,现在他们玩一个分糖果游戏。从 1 1 1 号小朋友开始,将自己的糖果均分成 3 3 3 份(如果有多余的糖果,就自己立即吃掉),自己留一份,其余两份分给和他相邻的两个小朋友。接着 2 , 3 , 4 , 5 2,3,4,5 2,3,4,5 号小朋友也这样做。问一轮结束后,每个小朋友手上分别有多少糖果。
输入格式
一行,
5
5
5 个用空格隔开的 int
范围内的正整数,分别是游戏开始时
1
,
2
,
3
,
4
,
5
1,2,3,4,5
1,2,3,4,5 号小朋友手里糖果的数量。
输出格式
2 2 2 行,第 1 1 1 行是用一个空格隔开的 5 5 5 个整数,表示一轮游戏结束后 1 , 2 , 3 , 4 , 5 1,2,3,4,5 1,2,3,4,5 号小朋友手里糖果的数量。第 2 2 2 行是一个整数,表示一轮游戏过程中吃掉的糖果的总数。
样例 #1
样例输入 #1
8 9 10 11 12
样例输出 #1
11 7 9 11 6
6
我的
思路:
代码顺序和生活顺序是不一样的 应该先分了糖果再去改变原本的值 一旦改了 后面分给别人的水果也会变
import java.util.Scanner;
public class LuoGu004 {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int a = scanner.nextInt();
int b = scanner.nextInt();
int c = scanner.nextInt();
int d = scanner.nextInt();
int e = scanner.nextInt();
int res = 0; // 8 9 10 11 12
res=a%3;b+=a/3;e+=a/3;a/=3; // 2 a2 b11 e14
res+=b%3;a+=b/3;c+=b/3;b/=3; // 4 b3 a5 c13
res+=c%3;b+=c/3;d+=c/3;c/=3; // 5 c4 b7 d15
res+=d%3;c+=d/3;e+=d/3;d/=3; // 5 d5 c9 e19
res+=e%3;d+=e/3;a+=e/3;e/=3; // 6 e6 d11 a11
System.out.printf("%d %d %d %d %d",a,b,c,d,e); //11 7 9 11 6
System.out.println();
System.out.println(res);
}
}
方法二
思路:从上面其实也可以看出来 很多地方是重复的 可以把他们存到一个数组里 然后循环遍历会比这个代码更清爽
import java.util.Scanner;
public class LuoGu004 {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int a = scanner.nextInt();
int b = scanner.nextInt();
int c = scanner.nextInt();
int d = scanner.nextInt();
int e = scanner.nextInt();
int num[5],ans=0;//分别存贮小朋友的糖数,吃掉的糖数
for(int i=0;i<5;i++){
int t=num[i]/3;//表示平均分成三份
//考虑两个边界问题 第一个小朋友和最后一个
if(i==0)num[4]+=t;//第一个小朋友应该给最后一个小朋友,
else num[i-1]+=t;
if(i==4)num[0]+=t;//最后一个小朋友应该给第一个小朋友,
else num[i+1]+=t;
ans+=num[i]%3;//加上这一次吃掉的糖,也就是除以三的余数
num[i]=t;//当前值应该变成原来的1/3
}
System.out.printf("%d %d %d %d %d",a,b,c,d,e);
System.out.println();
System.out.println(res);
}