Least Common Multiple
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 303 Accepted Submission(s) : 93
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
105
10296
Source
East Central North America 2003, Practice
#include<iostream>
using namespace std;
int gcd(long long x,long long y)
{
if (x % y == 0)
return y;
else
return gcd(y, x % y);
}
int main()
{
int n, m;
cin >> n;
while (n--)
{
long long a = 1, b;
cin >> m;
while (m--)
{
cin >> b;
a = b * a / gcd(b, a);
}
cout << a << endl;
}
return 0;
}