统计数字出现的次数

统计数字出现的次数

Time Limit: 1000/1000MS (C++/Others) Memory Limit: 65536/65536KB (C++/Others)
Total Submissions: 4 Accepted Submissions: 1
Problem Description
要求统计整数中指定数字出现的次数

Input
输入有多行,每行有两个整数n和d(0<=d<10)。

Output
输出n中d数字出现的次数。

Sample Input
12234 2
123 4

Sample Output
2
0

#include <stdio.h>
#include <string.h>
int main()
{
	int num[10];
	char n[1000];
	int temp;
	while(~scanf("%s %d",&n,&temp))
	{
		for(int i = 0;i<10;i++) num[i] = 0;
		for(int i = 0;i<strlen(n);i++)
		{
			num[n[i]-'0']++;
		}
		printf("%d\n",num[temp]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值