Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

 

 因为输入样例最大不超过20位 ,而最大的long long 却仅有  2^64 = 1.844674407371 * 10 ^19,故需使用字符串来输入数字,我感觉有一点点像大数加法,但是是用数字来判断是否有它的出现

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string.h>
#include<cstdio>
#include<queue>
#include<cmath>
using namespace std;


int main()
{
    char a[25],b[25]={0};
    char num[10]={0};
    scanf("%s",a);
    int len=strlen(a);
    for(int i=0;i<len;i++)
    {
        int j=a[i]-'0';
        num[j]++;
    }
    int flag=0,flag1=0;
    for(int i=len-1;i>=0;i--)
    {
        int temp=a[i]-'0';
        temp=temp*2+flag;
        flag=0;
        if((temp-10)>=0)
        {
            temp=temp-10;
            flag=1;
        }
        num[temp]--;
        b[i+1]=temp+'0';
    }
    for(int i=0;i<10;i++)
    {
        if(num[i]!=0)//num[i]==0说明i这个数已经用了
        {
            flag1=1;
            break;
        }

    }
    if(flag1==1||flag==1)
            cout<<"No"<<endl;
        else {
            cout<<"Yes"<<endl;

        }
        if(flag==1)
            cout<<"1";//有没有产生第一位数进位
         for(int i=1;i<=len;i++)
                printf("%c",b[i]);
    return 0;

}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值