Black And White (DFS + 剪枝)

In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly ci cells.

Matt hopes you can tell him a possible coloring.
Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers ci (ci > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c1 + c2 + · · · + cK = N × M .
Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1).

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.
Sample Input
4
1 5 2
4 1
3 3 4
1 2 2 4
2 3 3
2 2 2
3 2 3
2 2 2
Sample Output
Case #1:
NO
Case #2:
YES
4 3 4
2 1 2
4 3 4
Case #3:
YES
1 2 3
2 3 1
Case #4:
YES
1 2
2 3
3 1

题意:
输入n,m,k,有k种颜料,以下k个数字分别代表第1,2,3…种颜料的数量。用这k种颜料填满n行m列的矩阵,每个位置填一份颜料,每个位置颜料颜色不能与上下左右的颜料颜色相同。颜料数刚好填满矩阵。

代码如下

#include <iostream>
#include <string>
#include <algorithm>
#include <queue>
#include <string.h>
#include <cstdio>
using namespace std;
int f[30],maz[6][6],n,m,k,flag,g[4][2]={1,0,-1,0,0,1,0,-1};
/*
剩下的格子的数量+1 >= 剩余最多种类颜色的两倍,否则必定会有同色相邻存在。
即 剩下的格子数大于等于 最多颜色的2倍-1
且 剩余格子数 = 最多颜色数 + 其他颜色数
有 最多颜 + 其它颜 +1 >= 2* 最多颜
得 其它颜 +1 >= 最多颜
可以理解为 最多颜色数 最多比其它总数多一个
*/
void dfs(int x,int y,int ste)
{
    int i,j,ju;
    for(i=1;i<=k;i++)
    if(f[i]>(n*m-ste+1)/2)//右:(剩余格子数 +1)/2   这里也是我栽坑的地方
        return;//没有这个条件会时间超限
    for(i=1;i<=k;i++)
    {
        if(!f[i])
            continue;
        ju=1;
        for(j=0;j<4;j++)
        {
            int a=x+g[j][0],b=y+g[j][1];
            if(a>=0&&a<=n&&b>=0&&b<m&&maz[a][b]==i)
            {
                ju=0;break;
            }
        }
        if(ju)
        {
            maz[x][y]=i;f[i]--;
            if(x<n&&y<m-1)
                dfs(x,y+1,ste+1);
            else if(x<n-1&&y==m-1)
                dfs(x+1,0,ste+1);
            if((x==n-1&&y==m-1)||flag)
            {
                flag=1;return;
            }
        f[i]++;maz[x][y]=0;
        }
    }
}
int main()
{
    int t,i,j;
    cin>>t;
    for(int q=1;q<=t;q++)
    {
        cin>>n>>m>>k;flag=0;
        for(i=1;i<=k;i++)
            cin>>f[i];
        memset(maz,0,sizeof(maz));
        dfs(0,0,0);
        cout<<"Case #"<<q<<":\n";
        if(flag)
        {
            cout<<"YES\n";
            for(i=0;i<n;i++)
                for(j=0;j<m;j++)
                {
                cout<<maz[i][j];
                if(j==m-1)
                    cout<<endl;
                else
                    cout<<' ';
                }
        }else
            cout<<"NO\n";
    }
    return 0;
}

致谢:https://blog.csdn.net/qq_27601815/article/details/53364794?ops_request_misc=%257B%2522request%255Fid%2522%253A%2522161727604116780265437595%2522%252C%2522scm%2522%253A%252220140713.130102334.pc%255Fall.%2522%257D&request_id=161727604116780265437595&biz_id=0&utm_medium=distribute.pc_search_result.none-task-blog-2allfirst_rank_v2~rank_v29-2-53364794.first_rank_v2_pc_rank_v29&utm_term=Black+And+White%28dfs%29+

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值