蓝桥杯日期问题——python求解

题目如下

标题:日期问题

小明正在整理一批历史文献。这些历史文献中出现了很多日期。小明知道这些日期都在1960年1月1日至2059年12月31日。令小明头疼的是,这些日期采用的格式非常不统一,有采用年/月/日的,有采用月/日/年的,还有采用日/月/年的。更加麻烦的是,年份也都省略了前两位,使得文献上的一个日期,存在很多可能的日期与其对应。

比如02/03/04,可能是2002年03月04日、2004年02月03日或2004年03月02日。

给出一个文献上的日期,你能帮助小明判断有哪些可能的日期对其对应吗?

输入

一个日期,格式是"AA/BB/CC"。 (0 <= A, B, C <= 9)

输入

输出若干个不相同的日期,每个日期一行,格式是"yyyy-MM-dd"。多个日期按从早到晚排列。

样例输入

02/03/04

样例输出

2002-03-04
2004-02-03
2004-03-02

资源约定:
峰值内存消耗(含虚拟机) < 256M
CPU消耗 < 1000ms

请严格按要求输出,不要画蛇添足地打印类似:“请您输入…” 的多余内容。

所有代码放在同一个源文件中,调试通过后,拷贝提交该源码。
不要使用package语句。不要使用jdk1.7及以上版本的特性。
主类的名字必须是:Main,否则按无效代码处理。

题目解析

这道题我想了好久,最后还是决定暴力求解,一共需要考虑三种情况

n = input()
a = []
m = {1:31, 2:30, 3:31,4:30,5:31,6:30,7:31,8:31,9:30,10:31,11:30,12:31}
a.append(n[:2])
a.append(n[3:5])
a.append(n[6:])
res = []
if int(a[0]) in range(60):
    res.append(['20'+a[0]])
    res[0].append(a[1])
    res[0].append(a[2])
    if int(a[2]) > m[int(a[1])] or int(a[1]) > 12:
        res[-1] = []
else:

    res.append(['19'+a[0]])
    res[0].append(a[1])
    res[0].append(a[2])
    if int(a[2]) > m[int(a[1])] or int(a[1]) > 12:
        res[-1] = []
if int(a[2]) in range(60):
    res.append(['20'+a[2]])
    res[1].append(a[1])
    res[1].append(a[0])
    if int(a[0]) > m[int(a[1])] or int(a[1]) > 12:
        res[-1] = []
else:

    res.append(['19'+a[2]])
    res[1].append(a[1])
    res[1].append(a[0])
    if int(a[0]) > m[int(a[1])] or int(a[1]) > 12:
        res[-1] = []
if int(a[2]) in range(60):

    res.append(['20'+a[2]])
    res[2].append(a[0])
    res[2].append(a[1])
    if int(a[0]) > 12 or int(a[1]) > m[int(a[0])]:
        res[-1] = []
else:

    res.append(['19'+a[2]])
    res[2].append(a[0])
    res[2].append(a[1])
    if int(a[0]) > 12 or int(a[1]) > m[int(a[0])]:
        res[-1] = []
a = []
print(res)
for i in range(3):
    if res[i] != []:
        a.append('-'.join(res[i]))
print(a)
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Leosaf

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值