05-树8 File Transfer(并查集)

05-树8 File Transfer

分数 25

作者 陈越

单位 浙江大学

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains N (2≤N≤104), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format:

I c1 c2  

where I stands for inputting a connection between c1 and c2; or

C c1 c2    

where C stands for checking if it is possible to transfer files between c1 and c2; or

S

where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

Sample Input 1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

Sample Output 1:

no
no
yes
There are 2 components.

Sample Input 2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

Sample Output 2:

no
no
yes
yes
The network is connected.

1)并查集:(按秩合并,路径压缩);

/**
    1)并查集:(按秩合并,路径压缩);
*/

#include <iostream>
#include <string>

using namespace std;

const int maxn=1e4+10;
int fath[maxn]={0};

int Find(int x);
void Union(int x,int y);

int main()
{
    int n;
    cin >> n;
    string op;
    int a,b;
    while(cin >> op,op!="S")
    {
        if(op=="C")
        {
            cin >> a >> b;
            a=Find(a),b=Find(b);
            if(a==b)
                cout << "yes\n";
            else
                cout << "no\n";
        }
        else
        {
            cin >> a >>b;
            Union(a,b);
        }
    }

    int flag=0;
    for(int i=1;i<=n;++i)
        if(fath[i]==0)
            ++flag;

    if(flag==1)
        cout << "The network is connected.\n";
    else
        printf("There are %d components.",flag);
    return 0;
}

int Find(int x)
{
    if(fath[x]==0)
        return x;
    else
        return fath[x]=Find(fath[x]);
}

void Union(int x,int y)
{
    x=Find(x);
    y=Find(y);
    if(x!=y)
        fath[x]=y;
}

2)我下次再遇到操作符与运算符在一行的时候,我一定分开写,不用string一起读入,
    后面再取运算符,两次都是犯这种错误,样例给的运算符是个位数,就想当然的把所有
    数字都想成了单数,我真是……
    直接用int 输入发便许多。

/**
    2)我下次再遇到操作符与运算符在一行的时候,我一定分开写,不用string一起读入,
    后面再取运算符,两次都是犯这种错误,样例给的运算符是个位数,就想当然的把所有
    数字都想成了单数,我真是……
    直接用int 输入发便许多。
*/

/**
#include <iostream>
#include <cstring>
#include <string>

using namespace std;

const int maxn=1e4+10;
int fath[maxn]={0};

int Find(int x);
void Union(int x,int y);

int main()
{
    memset(fath,-1,sizeof(fath));
    int n;
    cin >> n;
    getchar();
    string str;
    while(getline(cin,str),str!="S")
    {
        if(str[0]=='C')
        {
            int a=0,b=0;
            int index=2;  //我下次再遇到操作符与运算符在一行的时候,我一定分开写,不用string一起读入,后面再取运算符,两次都是犯这种错误,样例给的运算符是个位数,就想当然的把所有数字都想成了单数,我真是……
            for(index=2;index<str.size()&&str[index]!=' ';++index)
                a=a*10+str[index]-'0';
            for(++index;index<str.size();++index)
                b=b*10+str[index]-'0';
            a=Find(a),b=Find(b);

            if(a==b)
                cout << "yes\n";
            else
                cout << "no\n";
        }
        else
        {
            int a=0,b=0;
            int index=2;
            for(index=2;index<str.size()&&str[index]!=' ';++index)
                a=a*10+str[index]-'0';
            for(++index;index<str.size();++index)
                b=b*10+str[index]-'0';
            Union(a,b);
        }
    }

    int flag=0;
    for(int i=1;i<=n;++i)
        if(fath[i]<0)
            ++flag;

    if(flag==1)
        cout << "The network is connected.\n";
    else
        printf("There are %d components.",flag);
    return 0;
}

int Find(int x)
{
    if(fath[x]<0)
        return x;
    else
        return fath[x]=Find(fath[x]);
}

void Union(int x,int y)
{
    x=Find(x);
    y=Find(y);
    if(x!=y)
    {
        if(fath[x]<fath[y])
        {
            fath[x]+=fath[y];
            fath[y]=x;
        }
        else
        {
            fath[y]+=fath[x];
            fath[x]=y;
        }
    }
}
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值