PAT A1001 A+B Format

1001 A+B Format

分数 20

作者 CHEN, Yue

单位 浙江大学

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 要注意和为0的时候要进行特判,要注意分解之后输出的时候除了第一个数,后面的其他数都要进行三位输出,不足三位的用0补齐;

#include <iostream>
#include <vector>

using namespace std;

int main()
{
    int a,b;
    cin >> a >> b;
    a += b;
    
    vector<int> res;
    
    //先以1000为进制,将和进行分解,最后在逆序处理;
    while(a)
    {
        res.push_back(a % 1000);
        a /= 1000;
    }
    
    //注意和为0的时候要特判
    if(res.size() == 0)
         puts("0");
    
    int flag = 1;
    for(auto it = res.rbegin() ; it != res.rend() ; ++it)
    {
        if(flag)
        {
            flag = 0;
            cout << *it;
        }
        else
        {
            cout << ',';
            
            //后面的数字要输出三位数字,不足三位的用0补齐
            printf("%03d", abs(*it) );
        }
    }
    
    return 0;
        
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值