PAT A1004 Counting Leaves

1004 Counting Leaves

分数 30

作者 CHEN, Yue

单位 浙江大学

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

 

多叉树,用vector来存储孩子节点编号,注意,存储完成以后,还需要处理一下每个节点所在的层数,数据并不能保证父节点一定在子节点之前给出,这儿是一个坑。

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

struct Node
{
    vector<int> child;
    int layer;
    Node()
    {
        layer = 110; //输入最多100个节点,所以树高最高100层
    }
    
    bool operator < (const Node & a) const
    {
        return layer < a.layer;
    }
};

const int maxn = 110;
Node Adj[maxn];

int main()
{
    int n, m;
    cin >> n >> m;
    
    Adj[1].layer = 1; //编号为1的节点为根节点
    
    int u, v, k;
    for(int i=1;i<=m;++i)
    {
        cin >> u >> k;
        while(k--)
        {
            cin >> v;
            Adj[u].child.push_back(v);
        }
    }
    
    for(int i=1;i<maxn;++i)
    {
        u = i;
        for(int j=0;j<Adj[i].child.size();++j)
        {
            v = Adj[i].child[j];
            Adj[v].layer = Adj[u].layer + 1;
        }
    }
    
    sort(Adj,Adj+maxn);
    
    vector<int> res;
    for(int i=0;i<n;++i)
    {
        int pre = Adj[i].layer;
        int cnt;
        if(Adj[i].child.size() == 0)
            cnt = 1;
        else
            cnt = 0;
        
        while(Adj[i+1].layer == pre)
        {
            ++i;
            if(Adj[i].child.size() == 0)
                ++cnt;
        }
        
        res.push_back(cnt);
    }
    
    int flag = 1;
    for(auto a : res)
    {
        if(flag)
            flag = 0;
        else
            cout << ' ';
        cout << a;
    }
    
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值