并查集----How Many Tables

并查集的简单思想

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4
(以上题为例)
并查集无非就是对集合的合并与查找,它包括三个步骤:
1.并查集的初始化

//初始化
void begin1(){
    for(int i=1;i<=max1;i++){
        s[i]=i;
        height[i]=0;
    }
}

2.合并
(1).考虑合并时深度的优化

void to(int x,int y){
    x=find1(x);
    y=find1(y);
    if(height[x]!=height[y]){
        if(height[x]>height[y]){
            s[x]=y;
        }
        if(height[x]<height[y]){
            s[y]=x;
        }
    }
    else{
        height[x]=height[x]+1;
        s[y]=x;
    }
}

(2).不考虑合并时深度的优化

void to(int x,int y){
    x=find1(x);
    y=find1(y);
    if(x!=y)
    s[x]=y;
    //s[x]=s[y]//这样写也可以,因为已经查找过了,此时y=s[y];
    }

3.查找
(1).不考虑查找的优化

int find1(int x){
    if(x==s[x]){
        return x;
    }
    return find1(s[x]);
}

(2).考虑查找的优化

int find1(int x){
    if(x!=s[x])
        s[x]=find1(s[x]);
        return s[x];
}

先贴一段未优化的代码

#include <iostream>
#include <algorithm>
using namespace std;
const int max1=1050;
int s[max1+1];
int x,y;
//初始化
void begin1(){
    for(int i=1;i<=max1;i++){
        s[i]=i;
    }
}
//查找节点
int find1(int x){//全部便利
    if(x==s[x])
        return x;
    return find1(s[x]);
}
//合并
void to(int x,int y){
    x=find1(x);
    y=find1(y);
    if(x!=y){
        s[x]=s[y];
    }
}
int main(){
    int t;
    cin>>t;
    int n,m;
    while(t--){
        cin>>n>>m;
        begin1();
        for(int i=1;i<=m;i++){
            cin>>x>>y;
            to(x,y);
        }
        int ans=0;
        for(int i=1;i<=n;i++){
            if(s[i]==i)
                ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
}

最后是优化完成的代码

#include <iostream>
#include <algorithm>
using namespace std;
const int max1=1050;//最大深度不超过1000(题意)
int s[max1+1],height[max1+1];
int x,y;
//初始化
void begin1(){
    for(int i=1;i<=max1;i++){
        s[i]=i;
        height[i]=0;
    }
}
//查找节点
int find1(int x){
    if(x!=s[x])
        s[x]=find1(s[x]);
        return s[x];
}
//合并
void to(int x,int y){
    x=find1(x);
    y=find1(y);
    if(height[x]!=height[y]){
        if(height[x]>height[y]){
            s[x]=y;
        }
        if(height[x]<height[y]){
            s[y]=x;
        }
    }
    else{
        height[x]=height[x]+1;
        s[y]=x;
    }
}
int main(){
    int t;
    cin>>t;
    int n,m;
    while(t--){
        cin>>n>>m;
        begin1();
        for(int i=1;i<=m;i++){
            cin>>x>>y;
            to(x,y);
        }
        int ans=0;
        for(int i=1;i<=n;i++){
            if(s[i]==i)
                ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
}

我自己的理解:
优化的目的就是减少计算机运算量,方便更快的查找,并查集整体的难度不大,但需认真,就这样!!!

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

画江湖がº

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值