算法笔记入门(算法模拟图像)——问题 B: Hello World for U

题目描述

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h d

e l

l r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出

For each test case, print the input string in the shape of U as specified in the description.

样例输入

helloworld!

样例输出

h !
e d
l l
lowor

思路分析:本题主要考虑的是如何将输入的字符串的转换成u字形,并且主要是需要满足n1=n3<=n2(底边长度为n2,左右两边的长度为n1,n3),通过找规律发现字符数增长n1n2n3时候就是临界点,根据规律可以发现n1=(N+2)/3,n3=(N+2)/3,n2=(N-n1-n2),也可以进行判断,刚达到临界值的时候,n1的值取最大。

	int n1,n2,n3;
    for(n2=0;n2<=N;n2++){
        if((N+2-n2)%2==0){
            n1=n3=(N+2-n2)/2;
            if(n1<=n2)break;
        }//n1和n3存在上界,刚好满足条件的时候,即取得临界值。
    }
#include <cstdio>
#include <cstring>
int main()
{
    char str[100],ans[40][40];
    scanf("%s",str);
    //printf("%s\n",str);
    int N = strlen(str);
    //int n1=(N+2)/3,n3=n1,n2=N+2-n1-n3;

    int n1,n2,n3;
    for(n2=0;n2<=N;n2++){
        if((N+2-n2)%2==0){
            n1=n3=(N+2-n2)/2;
            if(n1<=n2)break;
        }//n1和n3存在上界,刚好满足条件的时候,即取得临界值。
    }
    //通过题意中的规律发现,来确定n1
    for(int i=1;i<=n1;i++){
        for(int j=1;j<=n2;j++){
            ans[i][j]=' ';//初始化,将ans数组全部赋值为空格;
        }
    }

    int pos = 0;//pos从0开始使用str数组
    for(int i=1;i<=n1;i++){
        ans[i][1]=str[pos++];//赋值左侧n1
    }

    for(int j=2;j<=n2;j++){
        ans[n1][j] = str[pos++];//挖去最左端字符,从左往右赋值n2
    }

    for(int i=n3-1;i>=1;i--){
        ans[i][n2]=str[pos++];//挖去最下端的字符,从下望上面赋值。
    }

    for(int i=1;i<=n1;i++){
        for(int j=1;j<=n2;j++){
            printf("%c",ans[i][j]);
        }
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值