07:计算多项式的值

07:计算多项式的值

总时间限制: 1000ms 内存限制: 65536kB

描述

对于多项式f(x) = ax3 + bx2 + cx + d 和给定的a, b, c, d, x,计算f(x)的值

输入

输入仅一行,包含5个实数,分别是x,及参数a、b、c、d的值,每个数都是绝对值不超过100的双精度浮点数。数与数之间以一个空格分开。

输出

输出一个实数,即f(x)的值,保留到小数点后7位。

样例输入

2.31 1.2 2 2 3

样例输出

33.0838692

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {

	public static void main(String[] args) {
		//对于多项式f(x) = ax3 + bx2 + cx + d 和给定的a, b, c, d, x,计算f(x)的值
		BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
		String line = "";
		try {
			while((line = bf.readLine())!=null) {
				String[] s = line.split(" +");
				double x = Double.parseDouble(s[0]);
				double a = Double.parseDouble(s[1]);
				double b = Double.parseDouble(s[2]);
				double c = Double.parseDouble(s[3]);
				double d = Double.parseDouble(s[4]);
				double res = a * Math.pow(x, 3) + b * Math.pow(x, 2) + c * x +d;
				System.out.printf("%.7f",res);
			} 
		} catch (IOException e) {
			// TODO Auto-generated catch block
			e.printStackTrace();
		}
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值