R7-7 cm2inch

Given foot and inch, the meter is (foot+inch/12)×0.3048.

What sould be the feet and inches for an input centimetre?

PS:One foot is 12 inches.

Input Format:

One integer in terms of cm.

Output Format:

One integer for the feet and another integer for the inches.

Sample Input:

170

Sample Output:

5 6

题解: 这个可以看成一个实数,可以看成两部分组成,整数部分由英尺组成,小数部分由英寸组成,我们要的是整数,所以n/30.48直接取整,小数部分带入公式即可

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int n = in.nextInt();
        int foot = (int)(n / 30.48);
        int inch = (int)((n / 30.48 - foot) * 12);
        System.out.println(foot + " " + inch);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值