L1-043 阅览室 (20 分)
天梯图书阅览室请你编写一个简单的图书借阅统计程序。当读者借书时,管理员输入书号并按下S
键,程序开始计时;当读者还书时,管理员输入书号并按下E
键,程序结束计时。书号为不超过1000的正整数。当管理员将0
作为书号输入时,表示一天工作结束,你的程序应输出当天的读者借书次数和平均阅读时间。
注意:由于线路偶尔会有故障,可能出现不完整的纪录,即只有S
没有E
,或者只有E
没有S
的纪录,系统应能自动忽略这种无效纪录。另外,题目保证书号是书的唯一标识,同一本书在任何时间区间内只可能被一位读者借阅。
输入格式:
输入在第一行给出一个正整数N
(≤10),随后给出N
天的纪录。每天的纪录由若干次借阅操作组成,每次操作占一行,格式为:
书号
([1, 1000]内的整数) 键值
(S
或E
) 发生时间
(hh:mm
,其中hh
是[0,23]内的整数,mm
是[0, 59]内整数)
每一天的纪录保证按时间递增的顺序给出。
输出格式:
对每天的纪录,在一行中输出当天的读者借书次数和平均阅读时间(以分钟为单位的精确到个位的整数时间)。
输入样例:
3
1 S 08:10
2 S 08:35
1 E 10:00
2 E 13:16
0 S 17:00
0 S 17:00
3 E 08:10
1 S 08:20
2 S 09:00
1 E 09:20
0 E 17:00
输出样例:
2 196
0 0
1 60
AC代码
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<sstream>
using namespace std;
typedef long long ll;
const int N=1010;
int vis[N];
int st[N];
int ed[N];
int main()
{
int n;
cin >> n;
while(n -- )
{
memset(vis, 0 ,sizeof vis);
char op[2];
int id, h, m;
int time = 0;
int count = 0;
while(~scanf("%d %s %d:%d",&id, op, &h, &m))
{
if(op[0] == 'S')
{
vis[id] = 1;
st[id] = h * 60 + m;
}
if(op[0] == 'E' && vis[id])
{
ed[id] = h * 60 + m;
time += ed[id] - st[id];
vis[id] = 0;
count ++ ;
}
if(!id)
{
if(count == 0) cout << 0 << ' ' << 0 << endl;
else cout << count << ' ' << (int)(time * 1.0 / count + 0.5) << endl;
break;
}
}
}
return 0;
}