roof(开N次方以及上下取整)

开N次方

pow()函数
头文件:#include<math.h>
形式:pow(x,y)
格式:

  1. 表示对x开y次方
  2. x,y,函数返回值都为double型
  3. y不可以为小数
  4. x,y不可同为0

上下取整函数

向上取整
形式:floor(x)
含义:floor(x)返回的是小于或等于x的最大整数,floor(x)是向负无穷大舍入
返回形式:double型(c语言)
eg:floor(-2.5)=-3

向下取整
形式:ceil(y)
含义:ceil(x)返回的是大于x的最小整数,ceil()是向正无穷大舍入
返回形式:double型(c语言)
eg:ceil(-2.5)=-2

应用:

Root of the Problem

Description
Given positive integers B and N, find an integer A such that AN is as close as possible to B. (The result A is an approximation to the Nth root of B.) Note that AN may be less than, equal to, or greater than B.

Input
The input consists of one or more pairs of values for B and N. Each pair appears on a single line, delimited by a single space. A line specifying the value zero for both B and N marks the end of the input. The value of B will be in the range 1 to 1,000,000 (inclusive), and the value of N will be in the range 1 to 9 (inclusive).

Output
For each pair B and N in the input, output A as defined above on a line by itself.

Example Input:
4 3
5 3
27 3
750 5
1000 5
2000 5
3000 5
1000000 5
0 0
Example Output:
1
2
3
4
4
4
5
16
AC代码(c语言)如下

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
int main()
{
    int N,B;
    double Z;
    int x,y,A;
    double a,b;
    while(scanf("%d%d",&B,&N)&&B&&N)
    {
        //pow(x,y)表示x的y次方
        //先对B开N次方
        Z=pow(B*1.0,1.0/N);
        //向上取整
        x=floor(Z);
        //向下取整
        y=ceil(Z);
        //上下取整的值更接近B的就是A,所以直接比较结果就行
        a=pow(x,N);//对向上取整的结果开N次方
        b=pow(y,N);//对向下取整的结果开N次方
        //上差值(B大):B-a
        //下差值(B小):b-B
        if(B-a>b-B)
            A=y;
        else
            A=x;
        printf("%lld\n",A);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值