杭电1052-Tian Ji -- The Horse Racing 贪心算法(有思路和注释)

Problem Description

Here is a famous story in Chinese history.

“That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.”

“Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.”

“Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian’s. As a result, each time the king takes six hundred silver dollars from Tian.”

“Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.”

“It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king’s regular, and his super beat the king’s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?”

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian’s horses on one side, and the king’s horses on the other. Whenever one of Tian’s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching…

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses — a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output

200
0

思路

1.先看双方目前最好的马
1.1如果田胜,则两者最强的马比赛
1.2如果王胜,则将田最弱的和王最强的比赛
1.3两者相等
1.3.1 比较两者目前最差的马
1.3.1.1 如果田胜,则两者最差的马比赛
1.3.1.2 如果田不胜,则将田最弱和王最强比赛

代码

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;
bool mycompare(int a, int b)
{
	return a > b;
}
int main()
{
	int n;
	while (cin >> n)
	{
		int ans = 0;
		int a[1005], b[1005];
		int ai = 0, bi = 0, aj = n - 1,  bj = n - 1;
		if(n == 0) break;
		for (int i = 0; i < n; i++)
		{
			cin >> a[i];//输入田
		}
		sort(a, a + n, mycompare);//排序田
		for (int i = 0; i < n; i++)
		{
			cin >> b[i];//输入王
		}
		sort(b, b + n, mycompare);//排序王
		while (n--)
		{
			//先看双方目前最好的马
			if (a[ai] > b[bi])//如果田胜,则两者最强的马比赛
			{
				ans += 200;
				ai++;
				bi++;
			}
			else if (a[ai] < b[bi])//如果王胜,则将田最弱的和王最强的比赛
			{
				ans -= 200;
				aj--;
				bi++;
			}
			else//两者相等
			{
				//比较两者目前最差的马
				if (a[aj] > b[bj])//如果田胜,则两者最差的马比赛
				{
					ans += 200;
					aj--;
					bj--;
				}
				else//如果田不胜,则将田最弱和王最强比赛
				{
					if (a[aj] < b[bi])ans -= 200;
					aj--;
					bi++;
				}
			}
		}
		cout << ans << endl;
	}
}

疑惑点

有一个思路尝试实现却报wrong answer
就是先把两个序列从大到小排序
将王和田最大的标记
1.田比王大 则标记田和标记王同时向后移动 ans+=200
2.田比王小 则标记王向后移动,田不变
3.田和王一样大,则标记田和标记王同时向后移动
最后当王全都遍历完,ans-=没遍历到的田*200
最后的ans就是答案
试了几个案例都是正确的,一直找不到问题在哪,麻烦研究过的大佬帮忙解答,谢谢。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值