L1-010 比较大小 JAVA语言

L1-010 比较大小

本题要求将输入的任意3个整数从小到大输出。

输入格式:

输入在一行中给出3个整数,其间以空格分隔。

输出格式:

在一行中将3个整数从小到大输出,其间以“->”相连。

输入样例:

4 2 8

输出样例:

2->4->8

import java.util.*;
class Main{
    public static void main(String[] args){
        Scanner sc= new Scanner(System.in);
        int[] arr = {sc.nextInt(),sc.nextInt(),sc.nextInt()};
        Arrays.sort(arr);
        for(int i = 0;i < arr.length;i++){
            System.out.println(arr[0]+"->"+arr[1]+"->"+arr[2]);
        }
    }
}

上面这个代码是错误的,错误之处是下面的输出结果。

import java.util.*;
class Main{
    public static void main(String[] args){
        Scanner sc= new Scanner(System.in);
        int[] arr = {sc.nextInt(),sc.nextInt(),sc.nextInt()};
        Arrays.sort(arr);
        System.out.println(arr[0]+"->"+arr[1]+"->"+arr[2]);    
    }
}

Scanner的新玩法,可以直接写在数组内部.

另外一种方法:

import java.util.Scanner;
class Main{
    public static void main(String[] args){
        Scanner sc = new Scanner(System.in);
        int a = sc.nextInt();
        int b = sc.nextInt();
        int c = sc.nextInt();
        int temp = 0;
        if(a>b){
          temp = a;
          a = b;
          b = temp;
            
        }
        if(a>c){
          temp = a;
          a = c;
          c = temp;
            
        }
        if(b > c){
          temp = b;
          b = c;
          c = temp;
            
        }
        System.out.println(a+"->"+b+"->"+c);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值