wormholes

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: NM, and W
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish

this

题意:从i出发能否利用时光机回到出发前(即回到i),不一定非要去过所有的点,
Bellman实现

思路:判断从i点到i点的权值是否小于0就行了,小于0,能,反之,不能

Bellman算法解析:https://blog.csdn.net/weixin_42100963/article/details/106059004

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
const int inf=0x3f3f3f3f;
using namespace std;
struct dd
{
	int x, y, z;
} w[100111];
int d[11110],k;
int bellman(int n)
{
	int  x, y, z;
	for(int i=1; i<=n; i++) d[i] = inf;
	d[1]=0;
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<k; j++)
		{
			x = w[j].x;
			y = w[j].y;
			z = w[j].z;
			if(d[x]<inf&&d[x]+z<d[y])
				d[y]=d[x]+z;
		}
	}
	for(int j=0; j<k; j++)//判断是否有负权回路
	{
		x = w[j].x;
		y = w[j].y;
		z = w[j].z;
		if(d[x]<inf&&d[x]+z<d[y])
			return 0;
	}
	return 1;
}
void add(int x, int y, int z)
{
	w[k].x = x;
	w[k].y = y;
	w[k++].z = z;
}
int main()
{
	int i,j;
	int z,x,y,n,m,T,l;
	scanf("%d", &T);
	while(T--)
	{
		k = 0;
		scanf("%d %d %d",&n,&m,&l);
		for(i=0; i<m; i++)
		{
			cin>>x>>y>>z;
			add(x, y, z);
			add(y, x, z);
		}
		for(i=0;i<l;i++)
		{
			cin>>x>>y>>z;
			add(x,y,-z);
		}
		if(!bellman(n))
			printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}

floyd实现

#include<stdio.h>
#include<string.h>
const int inf = 99999999;
int map[510][510];
int book[510],dis[510];
int main()
{ 
	int p,n,m,i,j,k,w,a,b,c,f;
	int s[210],e[210],t[210];
	scanf("%d",&p);
	while(p--)
	{
		scanf("%d%d%d",&n,&m,&w);
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				if(i==j)
					map[i][j]=0;
				else
					map[i][j]=inf;
			}
		for(i=1;i<=m;i++)//正权 
		{
			scanf("%d%d%d",&a,&b,&c);
			if(map[a][b]>c)
				map[b][a]=map[a][b]=c;
		}
		for(i=1;i<=w;i++)//负权 
		{
			scanf("%d%d%d",&a,&b,&c); 
			map[a][b]=-c;
		}
		f=0;
		for(k=1;k<=n;k++)
		{
			for(i=1;i<=n;i++)
			{
				for(j=1;j<=n;j++)
					if(map[i][j]>map[i][k]+map[k][j])
					{
						map[i][j]=map[i][k]+map[k][j];
					}
				if(map[i][i]<0)//是否满足条件,即从i点出发再回到i点能否遇到自己 
				{
					f=1;
					break;
				} 	
			}
			if(f) 
				break;
		}
		if(f)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值