Highways

该博客主要讨论如何在一个岛屿国家Flatopia中构建最经济的公路网络,使得所有城镇都能够通过公路相互到达。已知Flatopia的城镇位置,以及部分已有的公路连接。问题转化为求解最小生成树,以最小化新建公路的总长度。给出的解决方案是利用凝聚连通性(并查集)和 Kruskal's 算法来找出所需构建的新公路,以达到所有城镇连通且总成本最低的目标。
摘要由CSDN通过智能技术生成

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3

题意:N城镇数,接下来N行,城镇坐标,M已有道路数,接下来M行表示城镇之间的连通,

求是所有城镇连通的最小花费,不一定直达,城镇连通花费为两城镇之间的距离

解题思路:先求出各个城镇之间连通的花费,然后把已经连通的城镇之间的花费计为零

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int x[1010],y[1001];
int b[10011],n;
int a[1011][1101];
struct dd
{
	int x,y;
	double z;
} w[500101];
bool  cc(dd q,dd p)
{
	return q.z<p.z;
}
void init()
{
	for(int i=1; i<=n; i++)
		b[i]=i;
}
int find(int x)
{
	if(b[x]!=x)
	b[x]=find(b[x]);
	return b[x];
}
int main()
{
	int i,j,k=0,m;
	cin>>n;
	init();
	for(i=1; i<=n; i++)
		cin>>x[i]>>y[i];
	cin>>m;
	int xx,yy;
	for(i=0; i<m; i++)
	{
		cin>>xx>>yy;
		a[yy][xx]=a[xx][yy]=1;//用a数组标记那些已经连通的城镇
	}
	for(i=1; i<=n; i++)
		for(j=i+1; j<=n; j++)
		{
			w[k].x=i;
			w[k].y=j;
			if(a[i][j])//如果两个城镇已经连通,话费为0
				w[k++].z=0;
			else
				w[k++].z=sqrt(pow(x[i]-x[j],2)+pow(y[i]-y[j],2));
		}
	sort(w,w+k,cc);
	int sum=0,v=0;
	for(i=0; i<k; i++)
	{
		int t1=find(w[i].x);
		int t2=find(w[i].y);
		if(t1!=t2)
		{
			b[t1]=t2;
			if(!a[w[i].x][w[i].y])
				printf("%d %d\n",w[i].x,w[i].y);
			v++;
		}
		if(v==n-1)break;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值