数据结构与算法A实验七查找---7-1 电话聊天狂人

给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。

输入格式:

输入首先给出正整数N(≤105),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。

输出格式:

在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。

输入样例:

4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832

结尾无空行

输出样例:

13588625832 3

结尾无空行

1.使用map容器

#include<bits/stdc++.h>
using namespace std;
int main()
{
	map<string, int> m;
	map<string, int>::iterator it;
	int n, cnt = 0, f = 1;
	string s;
	cin >> n;
	for (int i = 0; i < n * 2; i++) {
		cin >> s;
		m[s]++;
	}
	for (it = m.begin(); it != m.end(); it++) {
		if (it->second > cnt) {
			f = 1;
			cnt = it->second;
			s = it->first;
		}
		else if (it->second == cnt) {
			f++;
			if (it->first < s)
				s = it->first;
		}
	}
	cout << s << " " << cnt;
	if (f != 1)
		cout << " " << f;
}

2.哈希函数(散列表)

 

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define N 12
 
typedef struct ListNode *Position;
typedef struct HTable *HashTable;
struct ListNode {
	char data[N];
	int count;
	Position next;
};
struct HTable {
	Position list;
	int size;
};
HashTable CreatTable(int n);
void Insert(HashTable H, char *key);
void Solve(HashTable H);
int NextPrime(int n);
 
int main() {
	int i, n;
	char key[N];
	HashTable H;
	scanf("%d", &n);
	H = CreatTable(n * 2);
	for (i = 0; i < 2 * n; i++) {
		scanf("%s", key);
		Insert(H, key);
	}
	Solve(H);
	return 0;
}
 
HashTable CreatTable(int n) {
	HashTable H;
	int i;
	H = (HashTable)malloc(sizeof(struct HTable));
	H->size = NextPrime(n);
	H->list = (Position)malloc(H->size*sizeof(struct ListNode));
	for (i = 0; i < H->size; i++) 
		H->list[i].next = NULL;	
	return H;
}
 
void Insert(HashTable H, char *key) {
	Position p, temp;
	int h;
	h = (atoi(key + 6)) % H->size;
	p = H->list[h].next;
	while (p && strcmp(p->data, key)) {
		p = p->next;
	}
	if (p) p->count++;
	else {
		temp = (Position)malloc(sizeof(struct ListNode));
		strcpy(temp->data, key);
		temp->count = 1;
		temp->next = H->list[h].next;
		H->list[h].next = temp;
	}
}
 
 
void Solve(HashTable H) {
	int i, max = 0, num;
	char min[N];
	Position p;
	for (i = 0; i < H->size; i++) {
		p = H->list[i].next;
		while (p) {
			if (p->count > max) {
				max = p->count;
				strcpy(min, p->data);
				num = 1;
			}
			else if (p->count == max) {
				num++;
				if (strcmp(p->data, min) < 0)
					strcpy(min, p->data);
			}
			p = p->next;
		}
	}
 
	if(num == 1)
		printf("%s %d\n", min, max);
	else
		printf("%s %d %d\n", min, max, num);
	
}
 
int NextPrime(int n) {
	int i, j;
	n = (n % 2) ? n + 2 : n + 1;
	for (i = n;; i += 2) {
		for (j = 3; j*j <= i && i%j; j++);
		if (j*j > i) break;
	}
	return i;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

趟水过河

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值