2513: 插入排序实验,OJ

Problem Description

使用插入排序算法对输入的n个整数,按照从小到大的顺序排序。

Input Description

第一行输入一个整数n(0<n<10000)。 
第二行输入n个整数。 

Output Description

输出排序后的整数,每个整数之间以一个空格分隔。
注意:最后一个整数后面没有空格。

Sample Input

10
11 34 82 7 64 98 47 18 79 20

Sample Output

7 11 18 20 34 47 64 79 82 98
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        int n;
        Scanner in=new Scanner(System.in);
        n=in.nextInt();
        int[] a=new int[n];
        int i;
        for(i=0;i<n;i++)
        {
            a[i]=in.nextInt();
        }
        int temp;
        for(i=0;i<n;i++)
        {
            if(i+1>=n)
                break;
            temp=a[i+1];
            if(temp<a[i])
            {
                for(int j=0;j<=i;j++)
                {
                    if(a[j]>temp)
                    {
                        int t;
                        t=temp;
                        temp=a[j];
                        a[j]=t;
                    }
                }
               a[i+1]=temp;

            }
        }



        for(i=0;i<n;i++)
        {
            if(i==0)
                System.out.print(a[i]);
            else
                System.out.print(" "+a[i]);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值