给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。
输入格式:
输入首先给出正整数N(≤100000),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。
输出格式:
在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。
输入样例:
4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832
输出样例:
13588625832 3
c++实现代码:
#include<iostream>
#include<map>
using namespace std;
int main(int argc, char const *argv[])
{
int n;
cin >> n;
map<string,int> tel;
while(n--)
{
string str1,str2;
cin >> str1 >> str2;
if(tel[str1]){
tel[str1]++;
}else{
tel[str1] = 1;
}
if(tel[str2]){
tel[str2]++;
}else{
tel[str2] = 1;
// tel.insert({str2,1});
}
}
//打印map
// cout << "start" << endl;
// for(auto i:tel)
// {
// cout << i.first << " " << i.second << endl;
// }
// cout << "end" << endl;
int max = 0;
int cnt = 1; //记录电话狂人的数量
string str,curr;
for(auto i : tel){
// cnt++;
if(max < i.second){
cnt = 1; //避免出现1,1,1,3的情况
max = i.second;
str = i.first;
}
else if(max == i.second)
{
cnt++;
curr = i.first;
if(curr.compare(str) == -1)
str = curr;
}
}
if(cnt == 1)
cout << str << " " << max << endl;
else
cout << str << " " << max << " " << cnt << endl;
return 0;
}
总结:
- map的插入,可以直接写成map[key] = value;或者写成map.insert({str,int});
- map中key和value的使用,可以在遍历过程中,如下进行遍历:
//第一种遍历方法
map<string,int> mm;
for(auto i : mm)
{
cout << i.first << " " << i.second << endl;
}
//第二种遍历方法
map<int,int> mm;
map<int,int>::iterator iter;
for(iter = mm.begin();iter != mm.end();iter++)
{
cout << iter.first <<" " << iter.second << endl;
- 字符串大小比较,str1.compare(str2),字典序比较str1和str2,如果str1 < str2 ,返回-1;如果str1 > str2 ,返回1;如果str1 == str2,返回0。