7-1 重排链表 (15 分)(C语言版)

给定一个单链表 L 1→L 2→⋯→L n−1→L n,请编写程序将链表重新排列为 L n →L 1→Ln−1→L 2→⋯。例如:给定L为1→2→3→4→5→6,则输出应该为6→1→5→2→4→3。

输入格式:
每个输入包含1个测试用例。每个测试用例第1行给出第1个结点的地址和结点总个数,即正整数N (≤10^5)。结点的地址是5位非负整数,NULL地址用−1表示。

接下来有N行,每行格式为:

Address Data Next

其中Address是结点地址;Data是该结点保存的数据,为不超过10^5的正整数;Next是下一结点的地址。题目保证给出的链表上至少有两个结点。

输出格式:
对每个测试用例,顺序输出重排后的结果链表,其上每个结点占一行,格式与输入相同。

输入样例:

00100 6
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

输出样例:

68237 6 00100
00100 1 99999
99999 5 12309
12309 2 00000
00000 4 33218
33218 3 -1
#include<stdlib.h>
#include<string.h>
#include<stdio.h>
typedef struct Node{
    int data;//存储数据
    int pre;//存储前一个节点的地址
    int next;//存储下一个节点的地址
}node;
int main()
{
    node str[100005];
    int i , n , ID , temp;
    scanf("%d%d",&ID , &n);
    for(i = 0 ; i < n ; i ++)
    {
        int ID1 , num , next;
        scanf("%d%d%d",&ID1 , &num , &next);
        str[ID1].data = num;
        str[ID1].next = next;//保存下一个节点的地址
        if(next != -1)
            str[next].pre = ID1;//储存前一个节点的地址
        if(next == -1)
        {
            temp = ID1;//记录最后一个节点的地址
        }
    }
    for(;;)
    {
        printf("%05d %d ",temp , str[temp].data);
        if(temp == ID)
        {
            printf("-1\n");
            break;
        }
        else
            printf("%05d\n",ID);
        temp = str[temp].pre;
        printf("%05d %d ",ID , str[ID].data);
        if(ID == temp)
        {
            printf("-1\n");
            break;
        }
        else
            printf("%05d\n",temp);
        ID = str[ID].next;
    }
    return 0;
}
重排链表,可以采取以下步骤: 1. 定义链表节点结构体,包含一个值和一个指向下一个节点的指针。 ```c struct ListNode { int val; struct ListNode *next; }; ``` 2. 创建一个辅助函数,用于翻转链表的后半部。 ```c struct ListNode* reverseList(struct ListNode* head) { struct ListNode *prev = NULL; struct ListNode *curr = head; struct ListNode *next = NULL; while (curr != NULL) { next = curr->next; curr->next = prev; prev = curr; curr = next; } return prev; } ``` 3. 定义一个辅助函数,用于合并两个链表。 ```c void mergeLists(struct ListNode* l1, struct ListNode* l2) { struct ListNode *temp1; struct ListNode *temp2; while (l2 != NULL) { temp1 = l1->next; temp2 = l2->next; l1->next = l2; l2->next = temp1; l1 = temp1; l2 = temp2; } } ``` 4. 定义主函数,实现链表重排。 ```c void reorderList(struct ListNode* head) { if (head == NULL || head->next == NULL) { return; } // 找到链表中点 struct ListNode *slow = head; struct ListNode *fast = head; while (fast->next != NULL && fast->next->next != NULL) { slow = slow->next; fast = fast->next->next; } // 翻转链表的后半部 struct ListNode *reversed = reverseList(slow->next); slow->next = NULL; // 合并前半部和翻转后的后半部 mergeLists(head, reversed); } ``` 这样,当你有一个链表头节点 `head` 后,你可以调用 `reorderList(head)` 函数来重排链表注意,在调用函数之前,确保该链表的节点顺序是正确的。 希望这能帮到你!如果有任何问题,随时提问。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值