描述
给定两个递增的整数集合,分别用链表A和B表示,求出A和B的差集(即仅由在A中出现而不在B中出现的元素所构成的集合),并以同样的形式存储,同时返回该集合的元素个数。要求空间复杂度为O(1)。
输入
多组数据,每组数据有三行,第一行为序列A和B的长度n和m,第二行为序列A的n个元素,第三行为序列B的m个元素(元素之间用空格分隔)。n=0且m=0时输入结束。
输出
对于每组数据输出两行,第一行是A和B的差集,第二行为差集中的元素个数,每个数据之间用空格分隔。
输入样例 1
5 5
1 3 5 7 9
1 2 3 4 5
3 4
1 2 6
2 4 5 7
0 0
输出样例 1
7 9
2
1 6
2
思路:
用一个全局num数组来标记第一个链表里的元素是否在第二个链表里出现过~搭配两个insert函数和一个计数器c,c是控制输出空格的量~
插入第一个链表的时候把数组对应data位置的值都设置成1,同时c++;
插入第二个链表的时候,如果数组对应位置已经是1了,就让它是0,说明第一个链表里有的元素“减去”了第二个链表里有的元素,同时c--;
遍历输出第一个链表,用num控制是否输出,若num[p->data]=1说明1有2无,输出~
注意用c控制输出空格的个数~末尾不要带多余的空格~
代码:
#include<string>
#include<iostream>
#include<map>
#include<vector>
#include<set>
#include<algorithm>
using namespace std;
int num[100];
int c = 0;
class Book
{
public:
string id, name;
float price;
};
typedef struct LNode
{
int data;
LNode* next;
}*linklist, LNode;
void Init(linklist &l)
{
l = new LNode;
l->next = NULL;
}
void Insert1(linklist &l,int n)
{
l = new LNode;
l->next = NULL;
linklist rear = l;
for (int i = 0; i < n; i++)
{
linklist p = new LNode;
cin >> p->data;
num[p->data] =1;
c++;
p->next = NULL;
rear->next = p;
rear = p;
}
}
void Insert2(linklist& l, int n)
{
l = new LNode;
l->next = NULL;
linklist rear = l;
for (int i = 0; i < n; i++)
{
linklist p = new LNode;
cin >> p->data;
if (num[p->data] == 1)
{
c--;
num[p->data] = 0;
}
p->next = NULL;
rear->next = p;
rear = p;
}
}
void Minus(linklist l)
{
linklist p = l->next;
int i = 0;
while (p)
{
if (num[p->data])
{
cout << p->data;
i++;
if (i != c)
cout << " ";
}
p = p->next;
}
cout <<endl << c;
}
int main()
{
linklist l1,l2;
Init(l1);
Init(l2);
int n1, n2;
while(cin >> n1 >> n2&&n1!=0&&n2!=0)
{
c = 0;
for (int i = 0; i < 100; i++)
num[i] = 0;
Insert1(l1, n1);
Insert2(l2, n2);
Minus(l1);
cout << endl;
}
return 0;
}