华为无线AC间三层漫游

1、拓扑

2、配置

CE1配置

interface GE1/0/0
 undo shutdown
 port link-type trunk
 port trunk allow-pass vlan 100
#
interface GE1/0/1
 undo shutdown
 port default vlan 1000
 stp edged-port enable
#
interface GE1/0/2
 undo shutdown
 port link-type trunk
 port trunk pvid vlan 100
 port trunk allow-pass vlan 100 to 101
 stp edged-port enable

interface Vlanif100
 ip address 192.168.100.2 255.255.255.0
#
interface Vlanif101
 ip address 192.168.101.2 255.255.255.0
#
interface Vlanif1000
 ip address 10.1.1.1 255.255.255.252
vlan batch 100 to 101 1000
#
dhcp enable
#
ip pool vlan100
 gateway-list 192.168.100.2 
 network 192.168.100.0 mask 255.255.255.0
 excluded-ip-address 192.168.100.1
 dns-list 223.5.5.5 
#
ip pool vlan101
 gateway-list 192.168.101.2 
 network 192.168.101.0 mask 255.255.255.0
 dns-list 223.5.5.5 

ospf 1 router-id 1.1.1.1
 area 0.0.0.0
  network 10.1.1.1 0.0.0.0
 area 0.0.0.1
  network 192.168.100.0 0.0.0.255

CE2配置

interface GE1/0/0
 undo shutdown
 port link-type trunk
 port trunk allow-pass vlan 200
#
interface GE1/0/1
 undo shutdown
 port default vlan 1000
 stp edged-port enable
#
interface GE1/0/2
 undo shutdown
 port link-type trunk
 port trunk pvid vlan 200
 port trunk allow-pass vlan 200 to 201
 stp edged-port enable

interface Vlanif200
 ip address 192.168.200.2 255.255.255.0
#
interface Vlanif201
 ip address 192.168.201.2 255.255.255.0
#
interface Vlanif1000
 ip address 20.1.1.1 255.255.255.252

vlan batch 200 to 201 1000
#
dhcp enable
#
ip pool vlan200
 gateway-list 192.168.200.1 
 network 192.168.200.0 mask 255.255.255.0
 dns-list 223.5.5.5 
#
ip pool vlan201
 gateway-list 192.168.201.2 
 network 192.168.201.0 mask 255.255.255.0
 dns-list 223.5.5.5 

ospf 1 router-id 3.3.3.3
 area 0.0.0.0
  network 20.1.1.1 0.0.0.0
 area 0.0.0.1
 area 0.0.0.2
  network 192.168.200.0 0.0.0.255

AR1配置

interface GigabitEthernet0/0/0
 ip address 10.1.1.2 255.255.255.252 
#
interface GigabitEthernet0/0/1
 ip address 20.1.1.2 255.255.255.252 
#
ospf 1 router-id 2.2.2.2 
 area 0.0.0.0 
  network 10.1.1.2 0.0.0.0 
  network 20.1.1.2 0.0.0.0 

AC1配置

vlan batch 100 101
interface Vlanif100
 ip address 192.168.100.1 255.255.255.0
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 100

ip route-static 0.0.0.0 0.0.0.0 192.168.100.2
#
capwap source interface vlanif100

wlan
 security-profile name secu
  security wpa-wpa2 psk pass-phrase %^%#VLe/ZF:;4!xsi]-=zT`Xu!B]>xlrz@f!J#2ww^5J%^%# aes
 ssid-profile name ssid
  ssid wlan1
 vap-profile name vap1
  service-vlan vlan-id 101
  ssid-profile ssid
  security-profile secu

 mobility-group name manyou
  member ip-address 192.168.100.1
  member ip-address 192.168.200.1

 ap-group name default
  radio 0
   vap-profile vap1 wlan 1
  radio 1
   vap-profile vap1 wlan 1
  radio 2
   vap-profile vap1 wlan 1
 ap-id 0 type-id 47 ap-mac 00e0-fc6e-4cd0 ap-sn 210235448310AB1B5538
  ap-name AP1

AC2配置

vlan batch 200 to 201

interface Vlanif200
 ip address 192.168.200.1 255.255.255.0

interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 200

ip route-static 0.0.0.0 0.0.0.0 192.168.200.2
#
capwap source interface vlanif200

wlan

security-profile name secu
  security wpa psk pass-phrase %^%#U+R;(PdLR@.ws."XWQFHpdeI.&[p&7Yc^\+j^7l:%^%# aes
 ssid-profile name ssid
  ssid wlan1

 vap-profile name vap1
  service-vlan vlan-id 201
  ssid-profile ssid
  security-profile secu

 mobility-group name manyou
  member ip-address 192.168.100.1
  member ip-address 192.168.200.1


 ap-group name default
  radio 0
   vap-profile vap1 wlan 1
  radio 1
   vap-profile vap1 wlan 1
  radio 2
   vap-profile vap1 wlan 1
 ap-id 0 type-id 47 ap-mac 00e0-fc57-1be0 ap-sn 2102354483106F344119
  ap-name AP2

 3、当sta连接到AP1时,获取的是192.168.101网段IP地址

当sta漫游到AP2时,获取的时192.168.201网段IP地址

 4、查看漫游组状态

 5、查看sta漫游轨迹

6、查看sta接入信息

  • 1
    点赞
  • 12
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

I love this bad girl

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值