插花—动态规划


问题描述:

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers.

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0.

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

723-5-2416

2 (begonias)

521-41023

3 (carnations)

-21

5-4-2020

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4.

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement.

Input

  • The first line contains two numbers: FV.
  • The following F lines: Each of these lines contains V integers, so that Aij is given as the jth number on the (i+1)st line of the input file.
 

  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F.
  • F <= V <= 100 where V is the number of vases.
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j.

Output

The first line will contain the sum of aesthetic values for your arrangement.


样例输入:

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20


样例输出:

53


思路分析:

题目大意:本题是三种花放在五个花瓶中,放入不同的花瓶会产生不同的观赏价值,但必须按照顺序,只有1号放过了,才能放2号,以此类推。求产生的最大观赏价值是多少。

思路解析:还是得先确定dp数组的含义。这里我们就确定的是dp[i][j]表示前i种花放在前j号瓶中的价值。

当i=j,表示前i种放在j号瓶种,例如1号花放在1号瓶中,那么2号就直接可以放在二号瓶中了。

例如dp[2][2]=dp[1][1]+a[2][2],这就表示前两种花放在前两个瓶子中产生的观赏价值就等于1号花在1号瓶中的价值加上2号花在2号瓶中的价值。

所以dp[i][j]=dp[i-1][j-1]+a[i][j];

i不等于j的时候,例如:dp[4][2]=dp[4][1]或者dp[3][2]+a[4][3],同上推导理解。

    dp[i][j]=dp[i-1][j-1]+a[i][j]或dp[i][j-1],求个最大值就行了。


解决方案:

#include "stdio.h"
#include "string.h"
#include "algorithm"
using namespace std;
int a[110][110];
int dp[110][110];
int main ()
{
	int i,j,m,n;
	scanf("%d%d",&m,&n);
	for(i=1;i<=m;i++)
	for(j=1;j<=n;j++)
	scanf("%d",&a[i][j]);
	memset(dp,0,sizeof(dp));
	for(i=1;i<=m;i++)
	{
		for(j=i;j<=n;j++)
		{
			//两种不同情况的dp状态方程 
			if(i==j)
			dp[i][j]=dp[i-1][j-1]+a[i][j];
			else
			dp[i][j]=max(dp[i-1][j-1]+a[i][j],dp[i][j-1]);
		}
	}
	printf("%d\n",dp[m][n]);
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值