企业网三层架构

拓扑结构:

运用技术及重点:

svi.vlanif,E-thunk,stp,nat,acl(sw1为组1的根,为组2的备份根,sw2相反),由于HW不支持三层接口,则定义一个vlanif,将其划入vlan100。

sw1 

sysname sw1
#
undo info-center enable
#
vlan batch 2 100
#
stp instance 1 root primary
stp instance 2 root secondary
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
dhcp enable
#
diffserv domain default
#
stp region-configuration
 region-name a
 instance 1 vlan 1
 instance 2 vlan 2
 active region-configuration              
#                                         
drop-profile default                      
#                                         
ip pool vlan1                             
 gateway-list 172.16.1.126                
 network 172.16.1.0 mask 255.255.255.128  
 dns-list 114.114.114.114 8.8.8.8         
#                                         
ip pool vlan2                             
 gateway-list 172.16.1.254                
 network 172.16.1.128 mask 255.255.255.128
 dns-list 114.114.114.114 8.8.8.8         
#                                         
aaa                                       
 authentication-scheme default            
 authorization-scheme default             
 accounting-scheme default                
 domain default                           
 domain default_admin                     
 local-user admin password simple admin   
 local-user admin service-type http       
#                                         
interface Vlanif1                         
 ip address 172.16.1.1 255.255.255.128    
 vrrp vrid 1 virtual-ip 172.16.1.126      
 vrrp vrid 1 priority 101                 
 vrrp vrid 1 track interface GigabitEthernet0/0/1 reduced 2
 dhcp select global                       
#                                         
interface Vlanif2                         
 ip address 172.16.1.129 255.255.255.128  
 vrrp vrid 1 virtual-ip 172.16.1.254      
 dhcp select global                       
#                                         
interface Vlanif100                       
 ip address 172.16.0.1 255.255.255.252    
#                                         
interface MEth0/0/1                       
#                                         
interface Eth-Trunk0                      
 port link-type trunk                     
 port trunk allow-pass vlan 2 to 4094     
#                                         
interface GigabitEthernet0/0/1            
 port link-type access                    
 port default vlan 100                    
 stp edged-port enable                    
#                                         
interface GigabitEthernet0/0/2            
 port link-type trunk                     
 port trunk allow-pass vlan 2 to 4094     
#                                         
interface GigabitEthernet0/0/3            
 eth-trunk 0                              
#                                         
interface GigabitEthernet0/0/4            
 eth-trunk 0                              
#                                         
interface GigabitEthernet0/0/5            
 port link-type trunk                     
 port trunk allow-pass vlan 2 to 4094     
#                    

sw2

sysname sw2
#
undo info-center enable
#
vlan batch 2 100
#
stp instance 1 root secondary
stp instance 2 root primary
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
dhcp enable
#
diffserv domain default
#
stp region-configuration
 region-name a
 instance 1 vlan 1
 instance 2 vlan 2
 active region-configuration              
#                                         
drop-profile default                      
#                                         
ip pool vlan1                             
 gateway-list 172.16.1.126                
 network 172.16.1.0 mask 255.255.255.128  
 dns-list 114.114.114.114 8.8.8.8         
#                                         
ip pool vlan2                             
 gateway-list 172.16.1.254                
 network 172.16.1.128 mask 255.255.255.128
 dns-list 114.114.114.114 8.8.8.8         
#                                         
aaa                                       
 authentication-scheme default            
 authorization-scheme default             
 accounting-scheme default                
 domain default                           
 domain default_admin                     
 local-user admin password simple admin   
 local-user admin service-type http       
#                                         
interface Vlanif1                         
 ip address 172.16.1.2 255.255.255.128    
 vrrp vrid 1 virtual-ip 172.16.1.126      
 dhcp select global                       
#                                         
interface Vlanif2                         
 ip address 172.16.1.130 255.255.255.128  
 vrrp vrid 1 virtual-ip 172.16.1.254      
 vrrp vrid 1 priority 101                 
 vrrp vrid 1 track interface GigabitEthernet0/0/1 reduced 2
 dhcp select global                       
#                                         
interface Vlanif100                       
 ip address 172.16.0.5 255.255.255.252    
#                                         
interface MEth0/0/1                       
#                                         
interface Eth-Trunk0                      
 port link-type trunk                     
 port trunk allow-pass vlan 2 to 4094     
#                                         
interface GigabitEthernet0/0/1            
 port link-type access                    
 port default vlan 100                    
 stp edged-port enable                    
#                                         
interface GigabitEthernet0/0/2            
 port link-type trunk                     
 port trunk allow-pass vlan 2 to 4094     
#                                         
interface GigabitEthernet0/0/3            
 eth-trunk 0                              
#                                         
interface GigabitEthernet0/0/4            
 eth-trunk 0                              
#                                         
interface GigabitEthernet0/0/5            
 port link-type trunk                     
 port trunk allow-pass vlan 2 to 40

sw3

sysname sw3
#
undo info-center enable
#
vlan batch 2
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
stp region-configuration
 region-name a
 instance 1 vlan 1
 instance 2 vlan 2
 active region-configuration
#
drop-profile default
#
aaa
 authentication-scheme default            
 authorization-scheme default             
 accounting-scheme default                
 domain default                           
 domain default_admin                     
 local-user admin password simple admin   
 local-user admin service-type http       
#                                         
interface Vlanif1                         
#                                         
interface MEth0/0/1                       
#                                         
interface Ethernet0/0/1                   
#                                         
interface Ethernet0/0/2                   
#                                         
interface Ethernet0/0/3                   
 stp edged-port enable                    
#                                         
interface Ethernet0/0/4                   
 port link-type access                    
 port default vlan 2                      
 stp edged-port enable                    
#                      

sw4

sysname sw4
#
undo info-center enable
#
vlan batch 2
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
diffserv domain default
#
stp region-configuration
 region-name a
 instance 1 vlan 1
 instance 2 vlan 2
 active region-configuration
#
drop-profile default
#
aaa
 authentication-scheme default            
 authorization-scheme default             
 accounting-scheme default                
 domain default                           
 domain default_admin                     
 local-user admin password simple admin   
 local-user admin service-type http       
#                                         
interface Vlanif1                         
#                                         
interface MEth0/0/1                       
#                                         
interface Ethernet0/0/1                   
#                                         
interface Ethernet0/0/2                   
#                                         
interface Ethernet0/0/3                   
 stp edged-port enable                    
#                                         
interface Ethernet0/0/4                   
 port link-type access                    
 port default vlan 2                      
 stp edged-port enable                    
#                    

r1

acl number 2000  
 rule 1 permit source 172.16.0.0 0.0.255.255 
#
aaa 
 authentication-scheme default
 authorization-scheme default
 accounting-scheme default
 domain default                           
 domain default_admin                     
 local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
 local-user admin service-type http       
#                                         
firewall zone Local                       
 priority 15                              
#                                         
interface GigabitEthernet0/0/0            
 ip address 172.16.0.2 255.255.255.252    
#                                         
interface GigabitEthernet0/0/1            
 ip address 172.16.0.6 255.255.255.252    
#                                         
interface GigabitEthernet0/0/2            
 ip address 12.1.1.1 255.255.255.0        
 nat outbound 2000                        
#                                         
interface NULL0                           
#                                         
ospf 1 router-id 1.1.1.1                  
 default-route-advertise always           
 area 0.0.0.0                             
  network 172.16.0.0 0.0.255.255          
#                                         
ip route-static 0.0.0.0 0.0.0.0 12.1.1.2  
#                                      

r2

#                                         
interface GigabitEthernet0/0/0            
 ip address 12.1.1.2 255.255.255.0        
#                                         
interface GigabitEthernet0/0/1            
#                                         
interface GigabitEthernet0/0/2            
#                                         
interface NULL0                           
#                                         
interface LoopBack0                       
 ip address 2.2.2.2 255.255.255.0  

 测试(一个交换机坏,网络仍通):

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值