TZOJ——1471:Wall(凸包)

描述:

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.

 Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

输入:

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

输出:

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

样例输入:

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

样例输出:

1628

提示:

结果四舍五入就可以了


题目大意:给你n个点,和一个限制l,让你求这些点所构成的凸包的总边长,且凸包的边离任意一个点的距离要不小于l。

题目分析:这是一题关于凸包的板子题,我用的是graham算法来求凸包,时间复杂度是O(nlogn)。

如图,黄色的就是图上点集的凸包。

graham算法需要用到角排序,即找到一个定点,剩下的点进行排序,定点我一般是找这个点集里最左下角的点,即横坐标和纵坐标均最小。排序时要用到叉积,叉积可以用来判断点在向量的哪一边,比如A点位于向量OB的左边,则向量OB与向量OA叉积为正,反之为负。

graham中,会用到单调栈来维护下一个进入栈的元素始终在栈顶两元素向量的左边。如果在左边,则入栈;否则栈顶元素出栈。或者栈内元素个数小于2也入栈。

代码示例:

#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
#define ll long long
const int N=1e3+3;
const double pi=acos(-1);
struct node{
    int x,y;
}p[N],stk[N];
int n,top=0;
double dist(node a,node b)  //两点间距离
{
    double dx=a.x-b.x,dy=a.y-b.y;
    return sqrt(dx*dx+dy*dy);
}
double cross(node a,node b,node c)  //叉积
{
    return (b.x-a.x)*(c.y-a.y)-(c.x-a.x)*(b.y-a.y);
}
bool cmp(node l,node r)
{
    double x=cross(l,r,p[0]);
    if(x>0||x==0&&dist(l,p[0])<dist(r,p[0]))
        return true;
    return false;
}
void graham()
{
    int t=0;
    for(int i=1;i<n;i++)
        if(p[i].y<p[t].y||p[i].y==p[t].y&&p[i].x<p[t].x)
            t=i;
    swap(p[0],p[t]);    //将定点放在第一个位置
    sort(p+1,p+n,cmp);
    stk[1]=p[0],stk[2]=p[1],top=2;
    for(int i=2;i<n;i++)
    {
        while(top>=2&&cross(p[i],stk[top],stk[top-1])>=0)
            top--;
        stk[++top]=p[i];
    }
}
int main()
{
    double res;
    int l;
    scanf("%d%d",&n,&l);
    for(int i=0;i<n;i++)
        scanf("%d%d",&p[i].x,&p[i].y);
    graham();
    res=2*pi*l;
    for(int i=2;i<=top;i++)
        res+=dist(stk[i-1],stk[i]);
    res+=dist(stk[top],stk[1]); //之前这里忘加了,一直跑不出来。。
    printf("%d",(int)(res+0.5));    //四舍五入要记得+0.5
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

HYoung:)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值