银行排队问题之单队列多窗口服务(数学模拟问题)1017. Queueing at Bank (25)-PAT甲级真题

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤104) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

有n个客户,k个窗口。已知每个客户的到达时间和需要的时长,如果有窗口就依次过去,如果没有窗口就在黄线外等候(黄线外只有一个队伍,先来先服务),求客户的平均等待时长。银行开放时间为8点到17点,再8点之前不开门,8点之前来的人都要等待(转化为秒即小于28800),在17点后来的人不被服务。 

用一个结构体存储客户的到达时间和办理业务时间~首先把所有hh:mm:ss格式的时间全化成以当天0点为基准的秒数。注意晚于17:00的客户不算在内(转化为秒即大于61200)既然客户是排队的,那么排序后对于每个客户都是同样的处理方式~使用一个优先队列(priority_queue 相当于一个有序队列)维护窗口办理完业务的时间~如果最早结束服务的窗口时间早于客户的到达时间,不需要等待,直接执行 q.push(p[i].come + p[i].time)(直接入队,时间的大小位置会在priority_queue中自动排序);否则客户的等待时间是q.top() - p[i].come(累加求总的等待时间)

#include<bits/stdc++.h>
using namespace std;
const int maxn = 10005;
struct person
{
    int come, time; //结构体数组存储到达时间和等待时间
} p[maxn];
int n, k, cnt, total; //cnt为有效人数,total为等待总时间
int cmp(const person &p1, const person &p2) //对到达时间先后排序,即降序排序
{
    return p1.come < p2.come;
}
int main()
{
    cin >> n >> k;
    for(int i = 1; i <= n; i++)
    {
        int hh, mm, ss, tt;
        scanf("%d:%d:%d %d", &hh, &mm, &ss, &tt);
        int sum = hh * 3600 + mm * 60 + ss; //转化为秒
        if(sum > 61200) continue; //超过17点不服务
        p[++cnt].come = sum;
        p[cnt].time = tt * 60;
    }
    sort(p + 1, p + 1 + cnt, cmp); //排序
    priority_queue<int, vector<int>, greater<int>> q; //降序排序的队列
    for(int i = 1; i <= k; i++) q.push(28800); //将k个窗口最初的完成时间设置为开始办公时间,即8点
    for(int i = 1; i <= cnt; i++)
    {
        if(q.top() <= p[i].come) //如果最早结束服务的窗口时间早于客户的到达时间,不需要等待
        {
            q.push(p[i].come + p[i].time);
            q.pop();
        }
        else //否则等待
        {
            total += q.top() - p[i].come; //等待时间为上一个人办完的时间减去到达的时间
            q.push(q.top() + p[i].time); //这个人办完的时间为上一个办完的时间加上办理业务所需时间
            q.pop();
        }
    }
    if(!cnt)
        printf("0.0\n");
    else
        printf("%.1lf", ((double)total / 60.0) / (double)cnt);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Patrickstarԅ(¯ㅂ¯ԅ)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值