HDU 6914 Problem Select(“红旗杯”第十四届吉林省大学生程序设计竞赛 )

Problem Description

HOJ is an online judge system for students in HIT to practice. As the administrator, you would always setup contests by selecting problems from the problem set. Problem IDs are integers that can be phased by url. For example, the corresponding problem ID of url http://acm.hit.edu.cn/problemset/1001 is 1001.

Now the task is, given n urls, print the smallest k problem IDs in increasing order.

Input

The first line of the input contains one integer T (1 ≤ T ≤ 10), indicating the number of test cases.

For each test case, the first line contains two integers, n (1 ≤ n ≤ 1000) and k (1 ≤ k ≤ n).

For the next n lines,each line contains a string indicating the problem’s url. The problem ID is guaranteed to be in range [1,10000] and unique in each case.

Output

Output T lines.

For each test case, you should output k numbers in a line, and there shouldn’t be any spaces at the end of the line.

Sample Input

 

2 3 2

http://acm.hit.edu.cn/problemset/1003

http://acm.hit.edu.cn/problemset/1002

http://acm.hit.edu.cn/problemset/100

1 4 1

http://acm.hit.edu.cn/problemset/1001

http://acm.hit.edu.cn/problemset/2001

http://acm.hit.edu.cn/problemset/3001

http://acm.hit.edu.cn/problemset/501

Sample Output

1001 1002

501

思路:将每个网址的最后一个‘/’后的数字提取,进行排序后按要求输出即可

AC代码

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

int a[1010];
string s;

int main()
{
	int n,k,t;
	cin>>t;
	while(t--)
	{
		cin>>n>>k;
		for(int i=0;i<n;i++)
		{
			cin>>s;
			for(int j=s.size()-1;j>=0;j--)
				if(s[j]=='/')
				{
					int t=0;
					for(int k=j+1;k<s.size();k++)
						t=t*10+s[k]-'0';
					a[i]=t;
					break;
				}
		}
		sort(a,a+n);
		printf("%d",a[0]);
		for(int i=1;i<k;i++)
			printf(" %d",a[i]);
		puts("");
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Double.Qing

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值