HDU 4324 Triangle LOVE

Problem Description

Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.

 

Input

The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). Ai,j = 1 means i-th people loves j-th people, otherwise Ai,j = 0.
It is guaranteed that the given relationship is a tournament, that is, Ai,i= 0, Ai,j ≠ Aj,i(1<=i, j<=n,i≠j).

 

Output

For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.

 

Sample Input

 
 

2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110

 

Sample Output

 
 

Case #1: Yes Case #2: No

思路:要存在三角恋即存在环,可以通过拓扑排序来求解,如果存在拓扑序那么一定没有三角恋,如果不存在拓扑序那么图中至少存在一个环

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
using namespace std;

const int N=2010;

int n,t;
int h[N],e[N*N],ne[N*N],idx;
int d[N],q[N];

void add(int a,int b)
{
	e[idx]=b,ne[idx]=h[a],h[a]=idx++;
	d[b]++;
}

bool topsort()
{
	int hh=0,tt=-1;
	for(int i=1;i<=n;i++)
		if(!d[i])
			q[++tt]=i;
	while(hh<=tt)
	{
		int t=q[hh++];
		for(int i=h[t];~i;i=ne[i])
		{
			int j=e[i];
			if(--d[j]==0)
				q[++tt]=j;
		}
	}
	return hh==n;
}

int main()
{
	scanf("%d",&t);
	for(int k=1;k<=t;k++)
	{
		memset(h,-1,sizeof h);
		memset(d,0,sizeof d);
		idx=0;
		char s[N];
		scanf("%d",&n);
		getchar();
		for(int i=1;i<=n;i++)
		{
			scanf("%s",s+1);
			for(int j=1;j<=n;j++)
				if(s[j]=='1')
					add(i,j);
		}
		
		if(topsort())
			printf("Case #%d: No\n",k);
		else 
			printf("Case #%d: Yes\n",k);
	}
	
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Double.Qing

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值