AtCoder—C - ABC conjecture

Time Limit: 2 sec / Memory Limit: 1024 MB

Score : 300300 points

Problem Statement

You are given a positive integer NN.

Find the number of triples of positive integers (A, B, C)(A,B,C) such that A\leq B\leq CA≤B≤C and ABC\leq NABC≤N.

The Constraints guarantee that the answer is less than 2^{63}263.

Constraints

  • 1 \leq N \leq 10^{11}1≤N≤1011
  • NN is an integer.

Input

Input is given from Standard Input in the following format:

NN

Output

Print the answer.


Sample Input 1 Copy

Copy

4

Sample Output 1 Copy

Copy

5

There are five such triples: (1,1,1),(1,1,2),(1,1,3),(1,1,4),(1,2,2)(1,1,1),(1,1,2),(1,1,3),(1,1,4),(1,2,2).


Sample Input 2 Copy

Copy

100

Sample Output 2 Copy

Copy

323

Sample Input 3 Copy

Copy

100000000000

Sample Output 3 Copy

Copy

5745290566750
#include <iostream>
#include <stdio.h>
#include <cstring>

using namespace std;

typedef long long ll;

signed main() 
{
	ios_base::sync_with_stdio(false);
	cin.tie(0);
	cout.tie(0);
    ll N;
    cin >> N;
    ll ans = 0;
    for (ll a = 1; a <= N; a++)  //枚举第一项
	{
        if (a*a > N / a) break; //后面两项都大于第一项
        for (ll b = a; b <= N; b++)  //第二项
		{
            ll cma = N / (a * b);
            if (cma < b) break;
            ans += cma - b + 1;
        }
            
    }
    cout << ans << endl;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值