PAT甲级1072 Dijikstra

1072 Gas Station

分数 30

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤103), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤104), the number of roads connecting the houses and the gas stations; and DS​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

代码长度限制

16 KB

时间限制

200 ms

内存限制

 题目要求:

//找每个加油站的对每个房子的最短路
1.先是所有房子都在该加油站的服务范围

2.最短距离尽量大

3.平均路尽量小

4.编号尽量小的;
//最后输出编号,换行,最短的房子的路平均路

#include<bits/stdc++.h>
using namespace std;
int n,m,k,ds;
int mapdist[1011][1011];
vector<int> v[1011];
int mindist[1011];

//再有找每个加油站的对每个房子的最短路
    //1.先是所有房子都在该加油站的服务范围,2.最短距离尽量大,3.平均路尽量小,4.编号最小的;
//最后输出编号,换行,最短的房子的路平均路
struct record{
    int idx;
    int minhose = 100000000;
    int service = 1;
    double total = 0;
};
vector<record> vs;

void Dijikstra(int a){
    int visited[1011] = {0};
    int last = a;
    mindist[last] = 0;
    for(int i=1;i<=n+m;i++){
        visited[last] = 1;
        for(int j=1;j<=n+m;j++) mindist[j]=min(mindist[j],mindist[last]+mapdist[last][j]);
        int k=-1;
        for(int j=1;j<=n+m;j++) if(!visited[j]&&(k<0||mindist[j]<mindist[k])) k=j;
        last = k;
    }
}

int main(){
    memset(mapdist,0x3f,sizeof(mapdist));
    scanf("%d %d %d %d",&n,&m,&k,&ds);
    //输入
    string a,b;
    int l;
    for(int i=0;i<k;i++){
        cin>>a>>b;
        scanf("%d",&l);
        int p1=0;
        if(a[0]=='G'){
            for(int j=1;j<a.size();j++){
                p1 = p1*10+a[j]-'0';
            }
            p1+=n;
        }else{
            for(int j=0;j<a.size();j++){
                p1 = p1*10+a[j]-'0'; 
            }
        }
        int p2=0;
        if(b[0]=='G'){
            for(int j=1;j<b.size();j++) p2 = p2*10+b[j]-'0';
            p2+=n;
        }else for(int j=0;j<b.size();j++) p2 = p2*10+b[j]-'0'; 
        mapdist[p1][p2] = l;
        mapdist[p2][p1] = l;
        v[p1].push_back(p2);
        v[p2].push_back(p1);
    }
    
    for(int i=n+1;i<=n+m;i++){
        memset(mindist,0x3f,sizeof(mindist));
        Dijikstra(i);
        record s;
        s.idx = i-n;
        for(int j=1;j<=n;j++){
            if(s.minhose>mindist[j]) s.minhose = mindist[j];
            if(mindist[j]>ds){
                s.service = 0;
                break;
            }
            s.total+=mindist[j];
        }
        if(s.service) vs.push_back(s);
    }
    if(vs.empty()) cout<<"No Solution";
    else{ 
        sort(vs.begin(),vs.end(),[](record& a1,record& a2){
            if(a1.minhose!=a2.minhose) return a1.minhose>a2.minhose;
            else{
                if(a1.total!=a2.total) return a1.total<a2.total;
                else return a1.idx<a2.idx;
            }
        });
        cout<<'G'<<vs[0].idx<<endl;
        double df = round(vs[0].total/n*10);
        printf("%.1f %.1f",double(vs[0].minhose),df/10);
    }
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值