PAT甲级 1089 插入排序,归并排序

1089 Insert or Merge

分数:25

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

鸣谢用户 木子 补充数据!

代码长度限制

16 KB

时间限制

200 ms

内存限制

64 MB

题意:

给你插入排序和归并排序的排序过的一部分,你识别这是插入排序还是归并并且输出下一步

小坑:

对应插入排序,可能会有连续几步排序的结果是一样的,取最后一次排序结果走下一步噢~

解法:模拟排序过程每一次就与这一部分进行比较就可以了

如果看不懂代码可以看我的另一篇文章中的归并排序的实现:堆排序,快速排序,归并排序c++实现(附逻辑教程链接)-CSDN博客

#include<bits/stdc++.h>
using namespace std;

int a[100],b[100];//未排序 部分排序
int work[100];
int n;

void insertion(int k){//排序几个
    for(int i=0;i<n;i++) work[i]=a[i];
    sort(work,work+k);
}
void merge(int k){//分块个数
    for(int i=0;i<n;i++) work[i]=a[i];
    for(int i=0;i<n;i+=k){
        if(i+k<n) sort(work+i,work+i+k);
        else sort(work+i,work+n);
    }
}

bool issame(){
    for(int i=0;i<n;i++) if(work[i]!=b[i]) return false;
    return true;
}

int main(){
    cin>>n;
    for(int i=0;i<n;i++) cin>>a[i];
    for(int i=0;i<n;i++) cin>>b[i];
    for(int i=n;i>0;i--){
        insertion(i);
        if(issame()){
            insertion(i+1);
            cout<<"Insertion Sort"<<endl;
            for(int i=0;i<n;i++){
                if(i==0) cout<<work[i];
                else cout<<" "<<work[i];
            }
            return 0;
        }
    }
    for(int i=1;;i*=2){
        merge(i);
        if(issame()){
            merge(i*2);
            cout<<"Merge Sort"<<endl;
            for(int j=0;j<n;j++){
                if(!j) cout<<work[j];
                else cout<<" "<<work[j];
            }
            return 0;
        }
    }
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值