PAT甲级1143 LCA

1143 Lowest Common Ancestor

分数 30

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

代码长度限制

16 KB

时间限制

200 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
int n,m;
int s[10001];
unordered_set<int> se;
struct TreeNode{
    int val;
    TreeNode* left = nullptr,*right = nullptr;
    TreeNode(int val){
        this->val = val;
    }
};

TreeNode* build(int start,int end){
    if(start>end) return nullptr;
    TreeNode* root = new TreeNode(s[start]);
    int index=-1;
    for(int i=start+1;i<=end;i++){
        if(root->val<=s[i]){
            index = i;
            break;
        }
    }
    if(index!=-1){
        root->left = build(start+1,index-1);
        root->right = build(index,end);
    }else{
        root->left = build(start+1,end);
    }
    return root;
}

TreeNode* lca(TreeNode* root,int val1,int val2){
    if(root==nullptr) return nullptr;
    if(root->val==val1||root->val==val2) return root;
    TreeNode* left=lca(root->left,val1,val2);
    TreeNode* right=lca(root->right,val1,val2);
    if(left!=nullptr&&right!=nullptr) return root;
    return left==nullptr?right:left;
}


int main(){
    cin>>n>>m;
    for(int i=0;i<m;i++){
        cin>>s[i];
        se.insert(s[i]);
    }
    
    TreeNode* root = build(0,m-1);;
    
    int a1,a2;
    for(int i=0;i<n;i++){
        cin>>a1>>a2;
        if(se.find(a1)==se.end()&&se.find(a2)==se.end()) {
            cout<<"ERROR: "<<a1<<" and "<<a2<<" are not found."<<endl;
            continue;
        }
        if(se.find(a1)==se.end()){
            cout<<"ERROR: "<<a1<<" is not found."<<endl;
            continue;
        }
        if(se.find(a2)==se.end()){
            cout<<"ERROR: "<<a2<<" is not found."<<endl;
            continue;
        }
        TreeNode* root1 = lca(root,a1,a2);
        
        if(root1->val==a1){
            cout<<a1<<" is an ancestor of "<<a2<<"."<<endl;
        }else if(root1->val==a2){
            cout<<a2<<" is an ancestor of "<<a1<<"."<<endl;
        }else{
            cout<<"LCA of "<<a1<<" and "<<a2<<" is "<<root1->val<<"."<<endl;
        }
    }
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值