PAT甲级1114 并查集

文章描述了一个问题,要求根据给定的人员及其家庭成员信息,包括房产数量和总面积,计算每个家族的规模、平均房产套数和平均面积。输入是一个包含多个人及其亲属关系和房产信息的数据集,输出是按平均面积降序排列的家族信息。
摘要由CSDN通过智能技术生成

1114 Family Property

分数 25

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1​⋯Childk​ Mestate​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Childi​'s are the ID's of his/her children; Mestate​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVGsets​ AVGarea​

where ID is the smallest ID in the family; M is the total number of family members; AVGsets​ is the average number of sets of their real estate; and AVGarea​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

代码长度限制

16 KB

时间限制

200 ms

内存限制

64 MB

还以为会出错呢,没想到直接就过了,有点繁琐,把思路梳理清晰就好了

#include<bits/stdc++.h>
using namespace std;
struct node{
    int minid=10000,renshu=0,mianji=0,fangshu=0;
};
int father[10000],fangshu[10000]={0},mianji[10000]={0};
set<int> ren;
set<int> root;
node culset[10000];

int findfather(int x){
    if(x!=father[x]){
        father[x] = findfather(father[x]);
    }
    return father[x];
}

void _union(int x,int y){
    if(findfather(x)!=findfather(y)){
        father[findfather(x)] = findfather(y);
    }
}

int main(){
    int n;
    cin>>n;
    for(int i=0;i<10000;i++){
        father[i] = i;
    }
    for(int i=0;i<n;i++){
        int me;
        cin>>me;
        ren.insert(me);
        for(int j=0;j<2;j++){
            int parent;
            cin>>parent;
            if(parent!=-1){
                ren.insert(parent);
                _union(parent,me);
            }
        }
        int c;
        cin>>c;
        for(int j=0;j<c;j++){
            int child;
            cin>>child;
            ren.insert(child);
            _union(child,me);
        }
        cin>>fangshu[me]>>mianji[me];
    }
    
    for(auto i:ren){
        root.insert(findfather(i));
        culset[findfather(i)].minid = min(culset[findfather(i)].minid,i);
        culset[findfather(i)].renshu++;
        culset[findfather(i)].mianji+=mianji[i];
        culset[findfather(i)].fangshu+=fangshu[i];
    }
    
    vector<node> vv;
    for(auto o:root){
        vv.push_back(culset[o]);
    }
    sort(vv.begin(),vv.end(),[](node&a1,node&a2){
        if((a1.mianji/(double)a1.renshu)!=(a2.mianji/(double)a2.renshu)) return (a1.mianji/(double)a1.renshu)>(a2.mianji/(double)a2.renshu);
        return a1.minid<a2.minid;
        });
    cout<<vv.size()<<endl;
    for(auto o:vv){
        printf("%04d %d %.3f %.3f\n",o.minid,o.renshu,o.fangshu/(double)o.renshu,o.mianji/(double)o.renshu);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值