1154 简单a+b大数处理

简单a+b

题目描述

I have a very simple problem for you. Given two number A and B, your job is to calculate the Sum of A + B.

输入

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive number, A and B. Notice that the number are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 

输出

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

样例输入

2
1 2
112233445566778899 998877665544332211

样例输出

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

代码:

#include <stdio.h>

#include<string.h>

#define MAX 10000

int main()

{

  

    int i,up,t,j=1,n,s,m=0;

    scanf("%d",&n);

    for(s=0;s<n;s++)

    {

        char a[MAX+1]={0},b[MAX+1]={0},temp[MAX+1]={0},d[MAX+1]={0};

        scanf("%s",temp);

    for(t=0,i=strlen(temp)-1;i>=0;i--,t++)

    {

        d[t]=temp[i]-'0';

        a[t]=temp[i]-'0';

  

    }

  

    scanf("%s",temp);

    for(t=0,i=strlen(temp)-1;i>=0;i--)

    {

        b[t++]=temp[i]-'0';

    }

  

    for(up=0,i=0;i<MAX;i++)

    {

        t=a[i]+b[i]+up;

        a[i]=t%10;

        up=t/10;

    }

    printf("Case %d:\n",j);

    for(i=MAX;i>=0;i--)

    {

        if(d[i]!=0)

        {

            for(i;i>=0;i--)

            {

                printf("%d",d[i]);

                m++;

            }

        }

    }

    if(m==0)

        printf("0");m=0;

    printf(" + ");m=0;

    for(i=MAX;i>=0;i--)

    {

        if(b[i]!=0)

        {

            for(i;i>=0;i--)

            {

                printf("%d",b[i]);

                m++;

            }

        }

    }

    if(m==0)

        printf("0");m=0;

    printf(" = ");m=0;

    for(i=MAX;i>=0;i--)

    {

        if(a[i]!=0)

        {

            for(i;i>=0;i--)

            {

                printf("%d",a[i]);

                m++;

            }

        }

    }

    if(m==0)

        printf("0");m=0;

    printf("\n\n");j++;

    }

  

    return 0;

}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值