ZCMU--1427: Tram(C语言)

Description

Linear Kingdom has exactly one tram line. It has n stops, numbered from 1 to n in the order of tram's movement. At the i-th stop aipassengers exit the tram, while bi passengers enter it. The tram is empty before it arrives at the first stop. Also, when the tram arrives at the last stop, all passengers exit so that it becomes empty.

Your task is to calculate the tram's minimum capacity such that the number of people inside the tram at any time never exceeds this capacity. Note that at each stop all exiting passengers exit before any entering passenger enters the tram.

Input

The first line contains a single number n (2 ≤ n ≤ 1000) — the number of the tram's stops.
Then n lines follow, each contains two integers ai and bi (0 ≤ ai, bi ≤ 1000) — the number of passengers that exits the tram at the i-th stop, and the number of passengers that enter the tram at the i-th stop. The stops are given from the first to the last stop in the order of tram's movement.
The number of people who exit at a given stop does not exceed the total number of people in the tram immediately before it arrives at the stop. This particularly means that a1 = 0.
At the last stop, all the passengers exit the tram and it becomes empty.
No passenger will enter the train at the last stop. That is, bn = 0.

Output

Print a single integer denoting the minimum possible capacity of the tram (0 is allowed).

Sample Input

4
0  3
2  5
4  2
4  0

Sample Output

6
注意点:要多组输入,不会就判WA了🤷
解析:设每站下车a人,上车b人,每靠站之后增加人数就是b-a,所以我们每次靠站更新最大人数就ok。
#include <stdio.h>
int main()
{
	int n,m,r,a,b;
	while(~scanf("%d",&n)){
		m=0,r=0;//m记录最大人数,r记录当前车上人数 
		while(n--){
			scanf("%d%d",&a,&b);
			r+=b-a;//增加人数 
			if(r>m) m=r;//更新最大人数 
		}
		printf("%d\n",m);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值