ZCMU--1773: Mode

Description

Give you a number of n series, in which a number of more than n / 2 times , you should find out that the number (n<=500000,x<=10^19)

Input

The first line is a positive integer n. The second line of n positive integers separated by spaces.

Output

A Positive integer on a line indicates that number 

Sample Input

5

3  2  3  1  3

Sample Output

3

解析:就是让我们输出出现次数超过一半的那个数,但是x范围最多到10的19次方,long long也是存不下,所以我们直接用字符串类型,然后用map计数即可。

#include <map>
#include <string>
#include <iostream> 
using namespace std;
map<string,int> mp;
int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    string a,f;//f记录答案数
    int n;
    while(cin>>n)//题目没说,多组输入
    {
        mp.clear();//清空map
        for(int i=0;i<n;i++)
        {
            cin>>a;
            mp[a]++;//出现次数+1
            if(mp[a]>n/2) f=a;//超过一半记录一下答案  
        }
        cout<<f<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值