A - Pairs Forming LCM

本文解析了如何通过分析和优化代码,计算给定整数n下所有成对数的最小公倍数LCM等于n的情况。介绍了一种避免超时的方法,并详细解释了输入n的处理策略,包括利用质因数分解和特殊判断。通过实例展示了优化后的算法在不同测试用例中的性能提升。
摘要由CSDN通过智能技术生成

Find the result of the following code:

long long pairsFormLCM( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        for( int j = i; j <= n; j++ )
           if( lcm(i, j) == n ) res++; // lcm means least common multiple
    return res;
}

A straight forward implementation of the code may time out. If you analyze the code, you will find that the code actually counts the number of pairs (i, j) for which lcm(i, j) = n and (i ≤ j).

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1014).

Output

For each case, print the case number and the value returned by the function pairsFormLCM(n).

Sample Input

15
2
3
4
6
8
10
12
15
18
20
21
24
25
27
29

Sample Output

Case 1: 2
Case 2: 2
Case 3: 3
Case 4: 5
Case 5: 4
Case 6: 5
Case 7: 8
Case 8: 5
Case 9: 8
Case 10: 8
Case 11: 5
Case 12: 11
Case 13: 3
Case 14: 4
Case 15: 2
#include<iostream>
using namespace std;
#define ll long long 
const int N=1e7+10; 
ll n;
int t;
bool st[N];
int primes[N],cnt;
void get_prime(int n)
{
    st[1]=true;
    for(int i=2;i<=n;i++)
    {
        if(!st[i])primes[++cnt]=i;
        for(int j=1;primes[j]<=n/i;j++)
        {
            st[primes[j]*i]=true;
            if(i%primes[j]==0)break;
        }
    }
}
int main()
{    
    get_prime(N-9);
    cin>>t;
    int Case=0;
    while(t)
    {    
        int ans=1;
        Case++;
        t--;
        cin>>n;
        for(int i=1;i<cnt&&primes[i]<=n/primes[i];i++)
        {
            if(n%primes[i]==0)
            {    
                int s=0;
                while(n%primes[i]==0)n/=primes[i],s++;
                ans*=((s+1)*2-1);
            }
        }
        if(n>1)ans*=3;
        ans/=2;
        ans+=1;
        cout<<"Case "<<Case<<": "<<ans<<'\n';
    }
    return 0;
}


 

 增加通俗理解性;(这是对于个人理解,如果能帮助大家的话,乐意之至)

1,

18=(2^1)*(3^2);

那么对于要判断的i,j两个数,必须符合i和j当中的集合含有2^1和3^2这两个组合;(前后结合着理解)自己多带几个数试一下。

2,输入的n,在我们进行遍历时,只需便利到sqrt(n);即可;

3,对于   if(n>1)ans*=3;  的理解

这是因为当n=2,3时,由于sqrt(n)的原因无法进行便利,因此这里需要进行特判;

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值