OpenJudge 百练 1426:Find The Multiple

1426:Find The Multiple
描述

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

输入

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

输出

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

样例输入

2
6
19
0

样例输出

10
100100100100100100
111111111111111111

来源

Dhaka 2002

思路

简单的BFS即可
需要注意 数据超过了int类型 所以要用 long long
如果数据再大一点就需要使用高精度算法

#include<bits/stdc++.h>
using namespace std;

long long BFS(int n){
	queue<long long> que;
	que.push(1);
	while(!que.empty()){
		long long t =que.front();
		if(t % n==0) return t;
		for (int i=0; i<=1; ++i){
			que.push(t*10+i);
		}
		que.pop();
	}	
}
int main(){
	int n;
	
	while(cin >> n && n){
		cout << BFS(n) << endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值