运行springboot项目提示:java: 错误: 不支持发行版本 18、java: 错误: 无效的源发行版:18

java: 错误: 不支持发行版本 18

解决方法:修改字节码版本,可以多试几次。

java: 错误: 无效的源发行版:18

解决方法:

出现这些错误原因: spring版本与jdk版本不对应

我的spring boot版本是3.2.2,对应的jdk版本要大于17.

查看springboot对应版本的方法:

  1:打开spring官网 spring.io
                

        2:选择Projects->Springboot
               

        3:选择LEARN栏位
                

        4:点击对应版本的Reference Doc.
        ​​​​​​​        

        5:点击Getting Started
                

        6:点击Installing Spring Boot
                
        7:可以看到you need Java SDK v17

  • 8
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值