6-2 时间类 - 2. 设置和读取

代码示例展示了如何在C++中定义一个名为MYTIME的类,包含设置和读取时间的方法。类的成员变量包括小时、分钟和秒,Set方法接受1到3个参数来设置时间,Output方法格式化输出时间,Input方法从输入流读取时间,Get方法获取时间值。
摘要由CSDN通过智能技术生成

请为时间类添加设置、读取功能。

#include <iostream>
#include <iomanip>
using namespace std;

/* 你提交的代码将被嵌在这里 */

int main()
{
    MYTIME a;
    int h, m, s;

    cin >> h;
    a.Set(h);
    a.Output();
    cout << endl;

    cin >> h >> m;
    a.Set(h, m);
    a.Output();
    cout << endl;

    cin >> h >> m >> s;
    a.Set(h, m, s);
    a.Output();
    cout << endl;

    a.Input();
    a.Get(h, m, s);
    cout << h << ' ' << m << ' ' << s << endl;
    return 0;
}

输入样例

5
6 15
8 30 45
12:24:48

输出样例

05:00:00
06:15:00
08:30:45
12 24 48

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

答案

class MYTIME {
private:
    int hour;
    int minute;
    int second;
public:
    void Set(int h=0, int m=0, int s=0) { hour = h, minute = m, second = s; }
    void Output()
    {
        cout << setfill('0') << setw(2) << this->hour << ':' <<
            setfill('0') << setw(2) << this->minute << ':' <<
            setfill('0') << setw(2) << this->second;
    }
    void Input()
    {
            char sign = ':';
            cin >> this->hour >> sign >> this->minute >> sign >> this->second;
    }
    void Get(int &h,int &m,int &s)
    {
        h = this->hour;
        m = this->minute;
        s = this->second;
    }

};

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

拾-光

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值