With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W
for win, T
for tie, and L
for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.
For example, 3 games' odds are given as the following:
随着2010年国际足联世界杯的举行,世界各地的球迷越来越兴奋,因为来自最好球队的最好球员正在南非为世界杯奖杯而战。同样,足球博彩迷们通过在世界杯上下各种赌注,把钱花在了他们的嘴上。
中国足球彩票提供了一个“三赢”游戏。获胜的规则很简单:首先选择任意三场比赛。然后,对于每一场选定的比赛,下注三个可能结果中的一个,即W表示获胜,T表示平局,L表示失败。每个结果都有一个奇数。获胜者的奇数将是三个赔率乘以65%的乘积。
例如,3场比赛的赔率如下:
W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
To obtain the maximum profit, one must buy W
for the 3rd game, T
for the 2nd game, and T
for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).
为了获得最大利润,必须为第三场比赛购买W,为第二场比赛购买T,为第一场比赛购买T。如果每次下注2元,则最大利润为(4.1×3.1×2.5×65%−1)×2=39.31元(精确到小数点后2位)。
Input Specification:
Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W
, T
and L
.
每个输入文件包含一个测试用例。每个案例包含3场比赛的投注信息。每场比赛占据一条线,线上有三个不同的赔率,分别对应W、T和L。
Output Specification:
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.
对于每个测试用例,在一行中打印每个游戏的最佳赌注,最大利润精确到小数点后2位。字符和数字必须用一个空格分隔。
Sample Input:
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1
Sample Output:
T T W 39.31
水题,就不多赘述了。。。。。。
import java.util.ArrayList;
import java.util.Scanner;
class Main{
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
double []w = new double[3];
double []t = new double[3];
double []l = new double[3];
for(int i = 0 ; i < 3 ;i++)
{
w[i] = sc.nextDouble();
t[i] = sc.nextDouble();
l[i] = sc.nextDouble();
}
ArrayList<String> res = new ArrayList<>();
double sum = 1.0;
for(int i = 0 ;i < 3 ;i++ )
{
double max = 0;
String id = "";
if(max < w[i])
{
id = "W";
max = w[i];
}
if(max < t[i])
{
id = "T";
max = t[i];
}
if(max < l[i])
{
id = "L";
max = l[i];
}
res.add(id);
sum *= max;
}
for(String s : res)
{
System.out.print(s + " ");
}
System.out.printf("%.2f\n",(sum * 0.65 - 1) * 2);
}
}