(Java)1024 Palindromic Number分数 25

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

向前或向后书写时相同的数字被称为回文数。例如,1234321是一个回文数字。所有个位数都是回文数。

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

非回文数可以通过一系列运算与回文数配对。首先,将非回文数反转,并将结果添加到原始数上。如果结果不是回文数,则重复此操作,直到它给出回文数为止。例如,如果我们从67开始,我们可以分两步得到一个回文数:67+76=143,143+341=484。

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

给定任何正整数N,你应该找到它的配对回文数和找到它的步骤数。

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤1010) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

每个输入文件包含一个测试用例。每种情况由两个正数N和K组成,其中N(≤1010)是初始数字,K(≤100)是最大步数。这些数字用空格隔开。

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

对于每个测试用例,输出两个数字,每行一个。第一个数字是N的配对回文数,第二个数字是找到回文数所需的步骤数。如果在K步之后没有找到回文数,只需输出在第K步获得的数字和K。

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3
import java.math.BigInteger;
import java.util.Scanner;

class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        String num = sc.next();
        int k = sc.nextInt();
        int count = 0;
        while(k-- > 0)
        {
            if(ispalindromic(num))
            {
                break;
            }
            count ++;
            BigInteger bg1 = new BigInteger(num);
            StringBuilder sb = new StringBuilder(bg1.toString());
            String num2 = sb.reverse().toString();
            BigInteger bg2 = new BigInteger(num2);
            BigInteger bg3 = bg1.add(bg2);
            num = bg3.toString();
        }
        System.out.println(num);
        System.out.println(count);
    }

    private static boolean ispalindromic(String num) {
        int left = 0 ;
        int right = num.length() - 1;
        while(left < right)
        {
            if(num.charAt(left) != num.charAt(right))
            {
                return false;
            }
            left ++ ;
            right --;
        }
        return true;
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值