南阳理工58最少步数

最少步数
时间限制:3000 ms  |  内存限制:65535 KB
难度:4
描述
这有一个迷宫,有0~8行和0~8列:


 1,1,1,1,1,1,1,1,1
 1,0,0,1,0,0,1,0,1
 1,0,0,1,1,0,0,0,1
 1,0,1,0,1,1,0,1,1
 1,0,0,0,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,0,0,0,1
 1,1,1,1,1,1,1,1,1


0表示道路,1表示墙。


现在输入一个道路的坐标作为起点,再如输入一个道路的坐标作为终点,问最少走几步才能从起点到达终点?


(注:一步是指从一坐标点走到其上下左右相邻坐标点,如:从(3,1)到(4,1)。)


输入
第一行输入一个整数n(0<n<=100),表示有n组测试数据;
随后n行,每行有四个整数a,b,c,d(0<=a,b,c,d<=8)分别表示起点的行、列,终点的行、列。
输出
输出最少走几步。
样例输入
2
3 1  5 7
3 1  6 7
样例输出
12
11
来源
[苗栋栋]原创
上传者
苗栋栋

题意分析:这是最简单的搜索问题,用的是BFS,唯一注意的一点就是,当输入为两个点相等时,应该输出为0

#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
int dx[]={1,0,0,-1};
int dy[]={0,1,-1,0};
struct dot
{
    int x,y;
    int time;
};
inline bool in(dot gx)
{
    if(gx.x>=0&&gx.x<9&&gx.y>=0&&gx.y<9)
        return true;
    return false;
}
int main()
{
    int vis[9][9]={{1,1,1,1,1,1,1,1,1},{1,0,0,1,0,0,1,0,1},
                    {1,0,0,1,1,0,0,0,1},{1,0,1,0,1,1,0,1,1},
                    {1,0,0,0,0,1,0,0,1},{1,1,0,1,0,1,0,0,1},
                    {1,1,0,1,0,1,0,0,1},{ 1,1,0,1,0,0,0,0,1},
                    {1,1,1,1,1,1,1,1,1}};
    int test;
    int x1,x2,y1,y2;
    cin>>test;
    while(test--)
    {
        dot gx;
        cin>>x1>>y1>>x2>>y2;
        if(x1==x2&&y1==y2)
            cout<<0<<endl;
        else
        {

        gx.x=x1;
        gx.y=y1;
        gx.time=0;
        queue<dot>q;
        while(!q.empty())
            q.pop();
        q.push(gx);
        int step=0;
        while(!q.empty())
        {
            dot next,tmp;
            tmp=q.front(),q.pop();
            for(int i=0;i<4;i++)
            {
                next.x=tmp.x+dx[i];
                next.y=tmp.y+dy[i];
                next.time=tmp.time+1;
                if(in(next)&&!vis[next.x][next.y])
                {
                    q.push(next);
                    if(next.x==x2&&next.y==y2)
                    {
                        step=next.time;
                        break;
                    }
                }
            }
            if(step>0)
                break;
        }
        cout<<step<<endl;


    }
    }
    return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值