在Eclipse中添加struts.xml为什么会出现错误?

java 专栏收录该内容
23 篇文章 0 订阅

No1:你struts2的jar包导入齐全没有 ,在仓库里面找/在libraries找
No2:好像是struts2上面的配置有问题,应该是
<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE struts PUBLIC
    "-//Apache Software Foundation//DTD Struts Configuration 2.3//EN"
    "http://struts.apache.org/dtds/struts-2.3.dtd">

dtd版本要一致  之前我用的是struts2的jar包 是2.1.7的版本 现在我换了另一个版本的jar包2.3 但是struts.xml文件是copy之前的

所以会报一个错

先把我的struts.xml里的dtd改为和核心包里struts.defalut.xml默认的dtd规范

Referenced file contains errors (http://struts.apache.org/dtds/struts-2.3.dtd). For more information, right click on the message in the Problems View and select "Show Details..."

翻译出来是:

引用的文件包含错误(http://struts.apache.org/dtds/struts-2.3.dtd)。要了解更多信息,在Problems视图中右键单击消息并选择“Show”

细节……”

 

  • 0
    点赞
  • 0
    评论
  • 0
    收藏
  • 打赏
    打赏
  • 扫一扫,分享海报

参与评论 您还未登录,请先 登录 后发表或查看评论
©️2022 CSDN 皮肤主题:书香水墨 设计师:CSDN官方博客 返回首页

打赏作者

盖世小可爱

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值